open All Channels
seplocked EVE Technology Lab
blankseplocked phpBB3 API Registration Mod v3+
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: first : previous : ... 2 3 4 5 6 7 8 9 [10]

Author Topic

Kaomond
Posted - 2011.07.05 14:04:00 - [271]
 

Is there any chance you could look into making this work with the modx installe automod? I've tried using automod but it throws up an error unkown command as soon as you clck install, i'm a total clutz when it comes to these things and i'm scared to even attempt to manually install incase i ruin my forum.

Dal Brinium
Amarr
Nemesis Holdings Corp
The Paganism Alliance
Posted - 2011.07.06 11:40:00 - [272]
 

Hey there,

I have mailed Cyreus with an issue but thought I would share here my problems in case someone has already encountered and resolved it.


PhpBB3 mod for EVE API registration.
From: Dal Brinium
Sent: 2011.07.06 11:26
To: Cyreus,

Hello there,

First off let me say what a great job you all did creating the mod in the first instance.

Secondly let me say I am completely new to PHPBB3 but run several forums in Vbulletin and Joomla. I decided to create our corporate forums usnig PHPBB3 to make the most of the mod you have written.

So far everything works great except for the Avatar downloading.

So when trying to download thw avatar through the UsersCP I get an error.

[phpBB Debug] PHP Notice: in file /includes/functions_user.php on line 3538: file_put_contents(/1950f8c29cf9a2f4ce08f497ab3f262c_55.jpg) [function.file-put-contents]: failed to open stream: Permission denied
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4580: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3781)



Any ideas? Is everyone suffering from this since the API changes by CCP?


Many thanks in advance for any help.


Dal Brinium.

StyphonUK
Caldari
Fearless Bandits
Fearless Bears
Posted - 2011.07.31 10:37:00 - [273]
 

Hey Cyerus, any ETA on a version for 3.0.9. Can't update my forum because of some conflicting changes.

tha Sales
United Nations Organization
United Pod Service
Posted - 2011.08.01 16:05:00 - [274]
 

Originally by: Dal Brinium

So far everything works great except for the Avatar downloading.

So when trying to download thw avatar through the UsersCP I get an error.

[phpBB Debug] PHP Notice: in file /includes/functions_user.php on line 3538: file_put_contents(/1950f8c29cf9a2f4ce08f497ab3f262c_55.jpg) [function.file-put-contents]: failed to open stream: Permission denied
[phpBB Debug] PHP Notice: in file /includes/functions.php on line 4580: Cannot modify header information - headers already sent by (output started at /includes/functions.php:3781)



Any ideas? Is everyone suffering from this since the API changes by CCP?




Take a look at the file/dir permissions. It looks it can not write in the avater directory.

PS and i love an update to 3.09 i tried to install it on that version but i found some errors on new variables and got at the end a WSOD.

Admiral Tolwyn
Posted - 2011.08.02 12:37:00 - [275]
 

Edited by: Admiral Tolwyn on 03/08/2011 09:27:01
Hi,

I have a wish.
Would it be possible to write a normal small install howto, how to install this mod on phpbb3.
I have absolutely no idea how to work through this xml files.
I know in the phpbb community it has become very cool just to use this files but phpbb3 is the only thing I know which works like this.

Please help me out!

Thanks for your help!



Gore Neosilver
Posted - 2011.08.10 06:51:00 - [276]
 

Edited by: Gore Neosilver on 10/08/2011 08:03:51
Hi Admiral Tolwyn,
in the ZIP-File is a readme.txt. There you can read what to do, if you have not install any Mod yet. If you have install one, you have to open the XML-File in Firefox or Chrome. In the File is writen what to do and where. It is realy quit easy.

Now my Problem.
If i install your MOD in phpBB 3.0.8 it works. But if i make an update or install it on phpBB 3.0.9, i get the Error

SQL ERROR [ mysqli ]

Table 'mydb.LOGIN_ATTEMPT_TABLE' doesn't exist [1146]

Is this a known Error? Or do I something wrong?

Thanks for your reply.

P.S. sorry for my bad english

StyphonUK
Caldari
Fearless Bandits
Fearless Bears
Posted - 2011.08.12 18:52:00 - [277]
 

Originally by: Gore Neosilver
Edited by: Gore Neosilver on 10/08/2011 08:03:51
Hi Admiral Tolwyn,
in the ZIP-File is a readme.txt. There you can read what to do, if you have not install any Mod yet. If you have install one, you have to open the XML-File in Firefox or Chrome. In the File is writen what to do and where. It is realy quit easy.

Now my Problem.
If i install your MOD in phpBB 3.0.8 it works. But if i make an update or install it on phpBB 3.0.9, i get the Error

SQL ERROR [ mysqli ]

Table 'mydb.LOGIN_ATTEMPT_TABLE' doesn't exist [1146]

Is this a known Error? Or do I something wrong?

Thanks for your reply.

P.S. sorry for my bad english



3.0.9 changed some of the files that this mod changes. That means that Cyerus needs to edit the mod to work with 3.0.9.

Balani
Posted - 2011.08.14 21:31:00 - [278]
 

Someone can tell me how i can automaticaly add the Corporation and Alliance tag into profile field 1 and 2

Cyerus
Galactic Dominion
Eternal Strife
Posted - 2011.08.17 17:15:00 - [279]
 

Edited by: Cyerus on 17/08/2011 17:16:11
Working on it.

*shame* I missed the whole 3.0.9 release due to vacation, now I'm trying to catch up. Working as fast as I can guys ;)
Just hold with 3.0.8 for now, not many changes in 3.0.9 security wise.

EVEVERIFY Cashier
Posted - 2011.08.17 17:35:00 - [280]
 

Originally by: Cyerus
Edited by: Cyerus on 17/08/2011 17:16:11
Working on it.

*shame* I missed the whole 3.0.9 release due to vacation, now I'm trying to catch up. Working as fast as I can guys ;)
Just hold with 3.0.8 for now, not many changes in 3.0.9 security wise.


I'm wondering about the coming changes to api keys and how it relates to this mod?

Cyerus
Galactic Dominion
Eternal Strife
Posted - 2011.08.18 18:04:00 - [281]
 

Originally by: EVEVERIFY Cashier
Originally by: Cyerus
Edited by: Cyerus on 17/08/2011 17:16:11
Working on it.

*shame* I missed the whole 3.0.9 release due to vacation, now I'm trying to catch up. Working as fast as I can guys ;)
Just hold with 3.0.8 for now, not many changes in 3.0.9 security wise.


I'm wondering about the coming changes to api keys and how it relates to this mod?


In theory nothing big would change. You still need an UserID / APIkey pare, although named slightly different.

Only difference is that the user will have the chance to select what information to share per UserID / APIkey pair. In other words, he will need to set Username, Corporation and Alliance information in there, else the mod will deny him/her access.
When the changes are made final, I'll check out what permissions to set on the UserID / APIkey pair to have a fully functional check.

TL-DR:
Nothing to worry about.

Johnathan Roark
Caldari
The Graduates
Morsus Mihi
Posted - 2011.08.18 19:49:00 - [282]
 

Originally by: Cyerus
Originally by: EVEVERIFY Cashier
Originally by: Cyerus
Edited by: Cyerus on 17/08/2011 17:16:11
Working on it.

*shame* I missed the whole 3.0.9 release due to vacation, now I'm trying to catch up. Working as fast as I can guys ;)
Just hold with 3.0.8 for now, not many changes in 3.0.9 security wise.


I'm wondering about the coming changes to api keys and how it relates to this mod?


In theory nothing big would change. You still need an UserID / APIkey pare, although named slightly different.

Only difference is that the user will have the chance to select what information to share per UserID / APIkey pair. In other words, he will need to set Username, Corporation and Alliance information in there, else the mod will deny him/her access.
When the changes are made final, I'll check out what permissions to set on the UserID / APIkey pair to have a fully functional check.

TL-DR:
Nothing to worry about.


Instead of checking Characters, all you really need to do is check APIKeyInfo, returns the same info as Characters did.

Zylinda
Posted - 2011.08.26 19:07:00 - [283]
 

I'm about to setup a new corp forum, and was hoping to base it around PHPBB 3.0.9, and the Stargate Portal.

I'm more than happy to throw some ISK towards this project, as it is a very useful tool to use.

Just wondered if there is any ETA on a 3.0.9 update though before I decide whether to use 3.08 or not?

Zylinda
Posted - 2011.08.29 16:50:00 - [284]
 

Ok, I went ahead and installed this on a fresh installation of PHPBB v3.0.9

There is one error, which I'm guessing actually applies to all versions:

'INVALID_CHAR_NAME' isn't defined in the character files, so a new registration could get frustrated as they wouldn't see an error message.

However, following ALL the instructions (modifications to the php, adding the new files, and running the SQL updates), this API mod works perfectly.

The included 'api_cron.php' file can be used to automatically update all registered members to check change of corp/alliance membership. This can be run manually, or you could set this up with you host if you know how to.

You do have to edit the 3.0.9 files as listed in the 'install_api_registration_4.6.xml' file, so you CAN'T just copy in the files from 'pre_edit' directory as you could for 3.0.8

I hope this helps.

Pattux
Posted - 2011.09.01 16:29:00 - [285]
 

Doesn't work with the new API (Incarna 1.1) system.
The old API system does still work, but is deprecated.

Cyerus
Galactic Dominion
Eternal Strife
Posted - 2011.09.01 16:59:00 - [286]
 

Originally by: Pattux
Doesn't work with the new API (Incarna 1.1) system.
The old API system does still work, but is deprecated.



Working on it, release will be tomorrow.

Primus Doom
Posted - 2011.09.06 19:38:00 - [287]
 

/poke the dev.


just standing by :D id be willing to test any beta release =)


*starting up new forums for alliance and we wanted to implement this.


Pages: first : previous : ... 2 3 4 5 6 7 8 9 [10]

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only