open All Channels
seplocked EVE Technology Lab
blankseplocked TeamSpeak For EVE - API Registration for TS3 - Version 1.3 Released!
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: 1 2 3 4 [5]

Author Topic

Kamikazie
Amarr
Macabre Votum
Morsus Mihi
Posted - 2010.05.14 23:00:00 - [121]
 

Error: Cannot assign server group. Be sure that your name on the TeamSpeak server is correct. Your TeamSpeak name should be AWECO Kamikazie for verification. You can change it afterward.
Technical details:
(ID 0) invalid uri supplied


http://pastebin.com/raw.php?i=ndGacZ4C

Seigneur Doa
Ars ex Discordia
Test Alliance Please Ignore
Posted - 2010.06.30 20:05:00 - [122]
 

Edited by: Seigneur Doa on 01/07/2010 11:10:24
I'm close but can't get past this error:

Quote:
Checking: DEFI4NT - EVE Tough Error: Cannot assign server group. Be sure that your name on the TeamSpeak server is correct. Your TeamSpeak name should be EVE1 mfprincess for verification. You can change it afterward. Technical details: (ID 2560) invalid group ID


I saw on the teamspeak.com forums that it might have something to do with the group id, but I can't get that sorted. Any ideas?

Squizz Caphinator
Woopatang
Posted - 2010.07.02 14:09:00 - [123]
 

Here is my modified version of this tool that we used for the Primary. TS3 server.

I had to make modifications to the source when I initially downloaded the tool because it didn't work. Then, two different TS3 server upgrades broke the tool, which then required more source modification.

Use it but be aware that TS3 is beta and this tool is a mess. Enjoy:
http://www.mediafire.com/file/dxmhd5oydmi/teamspeak_for_eve.tgz

And no, I won't help you set it up :)

Webbe
Posted - 2010.07.27 19:05:00 - [124]
 

Just to give everyone a heads up the standings based registration does not work as intended...
For starters the standings API page is broken, standings returned are horribly out dated and a few debug lines I discovered that the two arrays used to hold Corp and alliance standings are empty...
When the function calls to check the standing it looks at the empty array and returns true. I tested this on an alt character who is neutral to the Corp/alliance who's API I'm using and sure enough it registered me under the other alliance server group.

Susan Fiona
Perkone
Posted - 2010.08.01 18:58:00 - [125]
 

Syntax error: Table 'itrek.client_properties' doesn't exist

I get this error when I register, yet it works just fine.

Just saying :)

/Susan

Susan Fiona
Perkone
Posted - 2010.08.04 22:11:00 - [126]
 

I forgot to say that the setup.php does not create said table when run, and I got no clue what the table should contain.


Agent Unknown
Caldari
Posted - 2010.08.07 15:00:00 - [127]
 

Please note that I no longer provide support for this software. It is out of date and some features no longer work. I'm currently working on a new version but it will take some time to complete.

Midge Mo'yb
Bat Country
Goonswarm Federation
Posted - 2010.08.09 11:13:00 - [128]
 

Originally by: Susan Fiona
Syntax error: Table 'itrek.client_properties' doesn't exist

I get this error when I register, yet it works just fine.

Just saying :)

/Susan



CREATE TABLE `client_properties` (
`ID` varchar(5) DEFAULT NULL,
`CID` varchar(10) DEFAULT NULL,
`ident` varchar(100) DEFAULT NULL,
`Name` varchar(100) DEFAULT NULL
) ENGINE=InnoDB DEFAULT CHARSET=latin1;

fixed it for me :P

MJ Maverick
IronPig
Sev3rance
Posted - 2010.08.12 00:58:00 - [129]
 

Edited by: MJ Maverick on 12/08/2010 17:08:55
Originally by: Squizz Caphinator
Here is my modified version of this tool that we used for the Primary. TS3 server.

I had to make modifications to the source when I initially downloaded the tool because it didn't work. Then, two different TS3 server upgrades broke the tool, which then required more source modification.

Use it but be aware that TS3 is beta and this tool is a mess. Enjoy:
http://www.mediafire.com/file/dxmhd5oydmi/teamspeak_for_eve.tgz

And no, I won't help you set it up :)


Magnificant, gj!

Just one question, does that mean that the "by standing" option now works?


Edit: Also how do I know if the cron is working? I don't get a log.txt appear and the page (and cron email) just says "cron runs from command line only".

MJ Maverick
IronPig
Sev3rance
Posted - 2010.08.12 21:50:00 - [130]
 

Originally by: Midge Mo'yb
Originally by: Susan Fiona
Syntax error: Table 'itrek.client_properties' doesn't exist

I get this error when I register, yet it works just fine.

Just saying :)

/Susan


I created that table but now get:

Syntax error: Unknown column 'value' in 'field list'
CREATE TABLE `client_properties` (
`ID` varchar(5) DEFAULT NULL,
`CID` varchar(10) DEFAULT NULL,
`ident` varchar(100) DEFAULT NULL,
`Name` varchar(100) DEFAULT NULL
) ENGINE=InnoDB DEFAULT CHARSET=latin1;

fixed it for me :P

Geonin
Amarr
No.Mercy
Merciless.
Posted - 2010.11.03 18:31:00 - [131]
 

Is this mod working with current ts3 server versions?



Agent Known
Posted - 2010.11.03 21:14:00 - [132]
 

Originally by: Geonin
Is this mod working with current ts3 server versions?





No. TS3 changed their code so the framework used in this software no longer works. Also, I dropped support on this over two months ago. Cool (Yes, this is an alt if it wasn't obvious enough)

I've recently decided to take a break from the game, but I may still try to develop something if the demand is still great enough to warrant recoding it. Please don't send me evemails as I don't log in to check them (and the account Unknown is on expired recently).

JaredC01
Noir.
Noir. Mercenary Group
Posted - 2010.11.07 22:15:00 - [133]
 

Originally by: Agent Known
Originally by: Geonin
Is this mod working with current ts3 server versions?





No. TS3 changed their code so the framework used in this software no longer works. Also, I dropped support on this over two months ago. Cool (Yes, this is an alt if it wasn't obvious enough)

I've recently decided to take a break from the game, but I may still try to develop something if the demand is still great enough to warrant recoding it. Please don't send me evemails as I don't log in to check them (and the account Unknown is on expired recently).


It seems to be working fine on one of my servers. I had to tweak it a bit for standings (manually entered instead of pulled until I can figure out how to pull the XML properly), but it's working fine.

Marta Shelder
Posted - 2010.11.21 15:31:00 - [134]
 

I hope your still watching Very Happy

I'm getting this error:
Corporation ID: x
Corporation Name: x
Alliance Name: x
Ticker: x

Checking: x - x

Error: Cannot assign server group. Be sure that your name on the TeamSpeak server is correct. Your TeamSpeak name should be x for verification. You can change it afterward.
Technical details:
(ID 0) php_network_getaddresses: getaddrinfo failed: Name or service not known

I've tried various settings, I've seen i.e. 127.0.0.1 local host but haven't had much luck. Any further tips would be greatfully recieved, thanks in advanced.

Lady Kah0s
Minmatar
Posted - 2010.11.21 17:10:00 - [135]
 

Originally by: Marta Shelder
I hope your still watching Very Happy

I'm getting this error:
Corporation ID: x
Corporation Name: x
Alliance Name: x
Ticker: x

Checking: x - x

Error: Cannot assign server group. Be sure that your name on the TeamSpeak server is correct. Your TeamSpeak name should be x for verification. You can change it afterward.
Technical details:
(ID 0) php_network_getaddresses: getaddrinfo failed: Name or service not known

I've tried various settings, I've seen i.e. 127.0.0.1 local host but haven't had much luck. Any further tips would be greatfully recieved, thanks in advanced.


set your ip to the outside ip of your server and add you servers ip to the whitelist of ts3

Marta Shelder
Posted - 2010.11.21 21:16:00 - [136]
 

Thanks but I think I may have a problem with this idea. I have added the IP address of the my_sql server to the query_ip_whitelist.txt and changed the config.php to reflect this. However I am having connection errors now and I think this due to the mysql database being behind a cPanel. I tried using the IP address instead of the dns name in the browser which causes errors. I resolved the IP by pinging the DNS name.

When you say "outside IP of the server" I'm thinking you meant that.

Marta Shelder
Posted - 2010.11.23 00:30:00 - [137]
 

I've narrowed it down to the serverquery statement
$ts = TeamSpeak3::factory("serverquery://serveradmin:x@x:10011/");
I keep getting a timeout. I can telnet to that ip:port and login ok with the user/pass I'm using. Error message:
Error: Cannot assign server group. Be sure that your name on the TeamSpeak server is correct. Your TeamSpeak name should be x for verification. You can change it afterward.
Technical details:
(ID 110) Connection timed out
I'm at a loss and I'm getting to the give up point, 3 days so far Very Happy


Jabberwockeee
Posted - 2010.11.23 03:06:00 - [138]
 

Edited by: Jabberwockeee on 23/11/2010 03:07:12
Quote:

Warning: Invalid argument supplied for foreach() in /home/****/public_html/ts/functions.php on line 155

Warning: Invalid argument supplied for foreach() in /home/****/public_html/ts/functions.php on line 155

Error: Cannot assign server group. Be sure that your name on the TeamSpeak server is correct. Your TeamSpeak name should be **** **** for verification. You can change it afterward.
Technical details:
(ID 0) invalid uri supplied


any one any idea's how to resolve this or know of a working script for this now the player was sitting on the server with correct UN?...

Marta Shelder
Posted - 2010.11.23 05:32:00 - [139]
 

Originally by: Jabberwockeee
Edited by: Jabberwockeee on 23/11/2010 03:07:12
Quote:

Warning: Invalid argument supplied for foreach() in /home/****/public_html/ts/functions.php on line 155

Warning: Invalid argument supplied for foreach() in /home/****/public_html/ts/functions.php on line 155

Error: Cannot assign server group. Be sure that your name on the TeamSpeak server is correct. Your TeamSpeak name should be **** **** for verification. You can change it afterward.
Technical details:
(ID 0) invalid uri supplied


any one any idea's how to resolve this or know of a working script for this now the player was sitting on the server with correct UN?...


I'd say it was something to do with the API you've enter. You need a full API. It could also be due the the $myname value to have entered. GL

Jabberwockeee
Posted - 2010.11.23 07:50:00 - [140]
 

If only... that and disabling the whole standings system just going by alliance names even tried using both server and server admin passwords seems like this a no hope lol. I seem to guess from reading this script only works via localhost settings and when its over multiple servers its dead as a door nail lol

Jabberwockeee
Posted - 2010.11.23 08:40:00 - [141]
 

Quote:
//ServerQuery Host
public $tshost = '*****.*****.net';
//TeamSpeak ServerQuery Name
public $tsname = '[Exact copy of TS Server name]';
//ServerQuery Password
public $tspass = '[Exact Server login/have tried admin token]';
//ServerQuery Port
public $tsport = '10011';
//TeamSpeak client port (this is not the same as the serverquery port!)
public $tscport = '9996';


All ports are correct and
Quote:
public $myname = '[Exact Alliance Name]';

is correct yet still when i hit "Register2 i get:

Quote:
Error: Cannot assign server group. Be sure that your name on the TeamSpeak server is correct. Your TeamSpeak name should be for verification. You can change it afterward.
Technical details:
(ID 0) invalid uri supplied


hehe dont suppose any one has any other idea's

Marta Shelder
Posted - 2010.11.23 09:09:00 - [142]
 

I think the database and the TS software need to be installed on the same box. I mean how the hell is the PHP software go to know certain things i.e. $ts = TeamSpeak3::factory("serverquery://. Thats in the php code for the API verification so if the server is installed elsewhere how is to know the serverquery trigger. O well, try and get that done in your case too if its not.

d3athmane
Caldari
Distinguished Gentleman's Boating Club
Test Alliance Please Ignore
Posted - 2011.02.14 03:40:00 - [143]
 


Checking: Many Of Honour - The Federation Workshop

Error: Cannot assign server group. Be sure that your name on the TeamSpeak server is correct. Your TeamSpeak name should be TFWS d3athmane for verification. You can change it afterward.
Technical details:
(ID 111) Connection refused


That is the error I am receiving. I have double checked to make sure that the SQL database is open for remote access, I have checked all severquery login and passwords, what else am I missing? Please help

Nuramori
Amarr
Drama Llamas
Posted - 2011.02.14 19:46:00 - [144]
 

I *Just* installed and tweaked this to work with the latest teamspeak.

Here were my gotchas.

The tshost value has to be your outside ip or URL that people use to get to your ts server. Example would be "ts3.pvpforever.com"

You have to go into tools and queryserver login and generate a login and password, then use that for the next two values. When you use the login tool you make up a login name and it will generate the password. Use those.

Make sure you comment out the code at the bottom as noted in the config.php file.

Make sure if you're just a corp to set alliance to false and corp to true or vice versa. This also is in the config.php file.

Double check your port settings if you changed them to non standard ts3 ports.

Make sure that you have checked and set the server group Id numbers correctly in config.php
I am also trying to add code that will in addition to Setting server group will set channel group. Not sure how successful I will be.

Emo Princess
Posted - 2011.02.25 14:05:00 - [145]
 

I am getting error (ID 0) invalid uri supplied. I seem to be connected to the server correctly however users cant reg. Any ideas?

MiniDevil
Posted - 2011.03.29 00:55:00 - [146]
 

Receiving

(ID 2561) duplicate entry

Anyone able to help me sort this out?

daddycaddy
ROMANIA Renegades
ROMANIAN-LEGION
Posted - 2011.04.26 00:06:00 - [147]
 

can someone give me the sql query for the tsclient table?
as there is no sql run to create it in the package
thanks

daddycaddy
ROMANIA Renegades
ROMANIAN-LEGION
Posted - 2011.04.26 00:08:00 - [148]
 

can someone give me the sql query for the tsclient table?
as there is no sql run to create it in the package
thanks

daddycaddy
ROMANIA Renegades
ROMANIAN-LEGION
Posted - 2011.04.26 00:19:00 - [149]
 

can someone give me the sql query for the tsclient table?
as there is no sql run to create it in the package
thanks

daddycaddy
ROMANIA Renegades
ROMANIAN-LEGION
Posted - 2011.04.26 00:21:00 - [150]
 

can someone give me the sql query for the tsclient table?
as there is no sql run to create it in the package
thanks


Pages: 1 2 3 4 [5]

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only