open All Channels
seplocked Market Discussions
blankseplocked EVEWalletAware (EWA) 2 - an offline wallet manager
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: first : previous : ... 2 3 4 5 [6] 7 8 9 10 ... : last (15)

Author Topic

Hel O'Ween
Men On A Mission
EVE Trade Consortium
Posted - 2010.09.18 10:31:00 - [151]
 

Originally by: Companion Qube

Speaking of .net, would you mind putting up the current source for the autodownloader? I'm interested in porting it to .net.


The downloader is part of the source code package. It's located in the zTOOLS\EWAAutoData folder. Everything in there is unique to the downloader (=not part of EWA), whereas the other sources of the downloader are taken from EWA's parent folder. In those, you'll find a couple of conditional compilation statements ...

#If APP_TYPE = ...

... which either disable some visual feedback from EWA for the downloader or make the downloader more responsive while downloading data.

I'll make sure the most recent version is uploaded on Monday.

Hel O'Ween
Men On A Mission
EVE Trade Consortium
Posted - 2010.10.07 10:34:00 - [152]
 

Thankfully this time around CCP announced data type changes in the API ahead of its implementation. (For those interested, here's the dev blog).

I just uploaded a new version of EWA, the database and the auto downloader. Although the above mentioned API change will be implemented with the release of Tyrannis 1.2, you can already apply the updates to EWA right now.

This update solely adds Tyrannis 1.2 compatibility to EWA and its DB. No new features this time, as I'm terribly busy in RL at the moment.

If you're using the auto downloader along with EWA, you must update both apps.

Deamonx32
Posted - 2010.10.19 00:30:00 - [153]
 

Edited by: Deamonx32 on 19/10/2010 00:32:55
Just want to say, awesome application been very happy with it.

The other day I transfered some ISK from one character to another, both characters are in EveWalletWare.

On one of the characters I can see the transaction in the journal, but on the other character I can not see the transaction in the journal. Any idea what I can do to fix/resolve this issue?

I have been using your app for a little over a month, monitoring my sales pretty much every day, this is the first time I have noticed something like this. I also figured maybe its just an API caching delay, but it has not resolved itself in over 3 days, also I am using the latest version of the application. I am not using the auto downloader.

Hel O'Ween
Men On A Mission
EVE Trade Consortium
Posted - 2010.10.19 09:11:00 - [154]
 

Originally by: Deamonx32

The other day I transfered some ISK from one character to another, both characters are in EveWalletWare.

On one of the characters I can see the transaction in the journal, but on the other character I can not see the transaction in the journal. Any idea what I can do to fix/resolve this issue?



Good catch. I think I know the reason why this happened, but need to verify that ingame sometime. At the moment I'm busy in RL and just log in to change skill.

If you're "life depends on it", send me an email to Hel.OWeen[at]eve-biotronics.de and we'll figure out how to add the missing record to that char.

Deamonx32
Posted - 2010.10.19 21:08:00 - [155]
 

Originally by: Hel O'Ween
Originally by: Deamonx32

The other day I transfered some ISK from one character to another, both characters are in EveWalletWare.

On one of the characters I can see the transaction in the journal, but on the other character I can not see the transaction in the journal. Any idea what I can do to fix/resolve this issue?



Good catch. I think I know the reason why this happened, but need to verify that ingame sometime. At the moment I'm busy in RL and just log in to change skill.

If you're "life depends on it", send me an email to Hel.OWeen[at]eve-biotronics.de and we'll figure out how to add the missing record to that char.


No worries, its not that important.
Thanks for the help and awesome application.

Warren Chest
Posted - 2010.10.19 22:02:00 - [156]
 

Thanks for this great app, I use it fo two years and it is very useful.

Last week, when retreiving datas from the API, I found something strange : the transactions for my corp did not appeared. The datas are correct in the journal or the personal ones but not the transactions for the corp ! Nothing was added since 10th october in the corporation wallet transaction table ...

Does anybody has this problem ?

Companion Qube
Minmatar
Electron Conservation Inc
SRS.
Posted - 2010.10.20 07:35:00 - [157]
 

Originally by: Warren Chest
Thanks for this great app, I use it fo two years and it is very useful.

Last week, when retreiving datas from the API, I found something strange : the transactions for my corp did not appeared. The datas are correct in the journal or the personal ones but not the transactions for the corp ! Nothing was added since 10th october in the corporation wallet transaction table ...

Does anybody has this problem ?

Under extras > maintenance try compacting the database. I've had weird problems like this before, usually from something leaving the DB in a strange state (power outage while running EWAAutoData, etc) - for whatever reason compacting has always fixed things.

Shadow First
Posted - 2010.10.22 20:23:00 - [158]
 

Edited by: Shadow First on 22/10/2010 20:27:34
nothing


Warren Chest
Posted - 2010.10.23 06:53:00 - [159]
 

Originally by: Companion Qube

Under extras > maintenance try compacting the database. I've had weird problems like this before, usually from something leaving the DB in a strange state (power outage while running EWAAutoData, etc) - for whatever reason compacting has always fixed things.


ty for the suggestion of compacting the database but that didn't change anything for meConfused

The problem first occured after importing datas from another computer because I had deleted some datas by error in the Corporation transaction table.Embarassed

I just do that for the moment : downloading data from another PC then export data from it to import to my main computer. It works like that but I would prefer to update directly like I used to...

Hel O'Ween
Men On A Mission
EVE Trade Consortium
Posted - 2010.10.25 20:31:00 - [160]
 

Edited by: Hel O''Ween on 25/10/2010 20:34:23
Originally by: Warren Chest

I just do that for the moment : downloading data from another PC then export data from it to import to my main computer. It works like that but I would prefer to update directly like I used to...


A couple of questions:

Is your version up to date (incl. the database)?

Any abnormal entries in the log (Extras -> Application log)? Try "Log -> Empty log" right before you try to download your corp transactions. Then check the log.

Also, check Extras -> Cached XML files. There should be six entries "Wallet transaction (corporation)". Click on them. Is there actually data in there?

One last point: You're using the same char to retrieve corp data on that second machine that does work? If not, has the char the necessary rights to retrieve API data?

Warren Chest
Posted - 2010.10.26 17:29:00 - [161]
 

Edited by: Warren Chest on 26/10/2010 22:49:47
My version is up to date (2.0.14 and Db ver 18). The transaction table works very well for personal datas on this machine; only corp transactions are concerned. Even the journal is OK and I can see the transactions in this one but without the details we get in the transactions report...

I found these entries in the log on start :

Error: -2147220988, EVE API Error: 516, Failed getting user information.

cEVEChars:GetEVEChars->457, EVEWalletAware, Cette clé est déjà associée à un élément de cette collection

after dowload of corp transactions :

Error: -2147221403, EVE API Error: 101, Wallet exhausted: retry after 2010-10-26 17:55:25. (5 of this type)

Error: -2147221387, EVE API Error: 117, Market orders already downloaded: retry after 2010-10-26 17:43:09.

regarding the cached xml files now : there are six entries for corp wallet transactions : some with datas, some without (the empty ones are the inactive corp wallets).

I use same character on the 2 machines, I also tried some alts but with no results.

ty for your help as I would like to keep my 2 years old database working ^^

Hel O'Ween
Men On A Mission
EVE Trade Consortium
Posted - 2010.10.27 00:13:00 - [162]
 

Originally by: Warren Chest

I found these entries in the log on start :

Error: -2147220988, EVE API Error: 516, Failed getting user information.

cEVEChars:GetEVEChars->457, EVEWalletAware, Cette clé est déjà associée à un élément de cette collection



Those two errors shouldn't occur. Did you by any chance change the corp with that character? That would explain that personal wallet transactions work just fine, but corporate not. If you did so, try retrieving the characters for that EWA account again. I suggest also to mark one EWA account as your default account, if you haven't already done so.

Quote:

after dowload of corp transactions :

Error: -2147221403, EVE API Error: 101, Wallet exhausted: retry after 2010-10-26 17:55:25. (5 of this type)



This is an informational entry. EWA queried all data available for that wallet division.

Quote:

regarding the cached xml files now : there are six entries for corp wallet transactions : some with datas, some without (the empty ones are the inactive corp wallets).



Again, that's the expected behavior. Data is downloaded (and stored) by EWA, no data is lost. There only seems to be a problem with displaying the data.

If my above suggestion doesn't work/is not applicable, send me an email at Hel.OWeen[at]eve-biotronics.de.

Companion Qube
Minmatar
Electron Conservation Inc
SRS.
Posted - 2010.10.27 05:39:00 - [163]
 

How do I go about emptying the log with a direct database query? I have something like 1 and a half years of heavy trading and I've never cleared the log - loading the log causes EWA to try and load everything into memory, which does bad things.

Hel O'Ween
Men On A Mission
EVE Trade Consortium
Posted - 2010.10.27 11:43:00 - [164]
 

Originally by: Companion Qube
How do I go about emptying the log with a direct database query?



DELETE * FROM tApplicationLog


You can also switch to text file logging instead writing the log to the DB. To do so, open EVEWalletAware.ini and enter the following line beneath the [General] section:

LogType=1


Deleting that line or changing the value to 0 will resume database logging again. Logging to a text file has the advantage that EWA autopurges log files older than 14 days. It has two disadvantages, though: a) can't view them from within EWA and b) logging is a bit slower.

Companion Qube
Minmatar
Electron Conservation Inc
SRS.
Posted - 2010.10.28 00:16:00 - [165]
 

Thanks, that cleaned things up nicely. You might appreciate this.

Hel O'Ween
Men On A Mission
EVE Trade Consortium
Posted - 2010.10.28 07:33:00 - [166]
 

Shocked

2 GB? That's a lot of log entries. I guess, I'll implement some kind of auto-purging for DB logging, too.

Companion Qube
Minmatar
Electron Conservation Inc
SRS.
Posted - 2010.10.28 11:47:00 - [167]
 

The DB was actually one of the single largest files on my SSD so I'd been monitoring it for a while - I'm pretty surprised that was all log entries though. I expected more was data.

Hel O'Ween
Men On A Mission
EVE Trade Consortium
Posted - 2010.10.30 11:35:00 - [168]
 

Edited by: Hel O''Ween on 30/10/2010 11:44:25
Originally by: Warren Chest

EWA problem report



Just a quick note, Warren: I received your emails, but my mail server currently has problems sending out emails.

In the meantime, see if the explanation under "Import wallet transactions/journals for" helps to clarify EWA's behavior.

Make that a "dumb user problem", not a mail server problem. Email sent.

Dmitri Kreig
Posted - 2010.11.06 05:38:00 - [169]
 

Hello!

I've been using this app for monitoring my assets for some time, great tool. But since the last patch, it displays only a minor part of my stuff. Cached XML file for Asset list query contains only several hundreds of rows, and if i'm guessing correctly, 1 row = 1 item (stack), in wich case there should be several thousands of them. App log entry for updating assets from API says: "Application Error: cEVEAssets:ParseXML->6, EVEWalletAware, Overflow". My OS is XP.

Anyone has the same problem? Any tips?

Hel O'Ween
Men On A Mission
EVE Trade Consortium
Posted - 2010.11.06 14:52:00 - [170]
 

There seem to be two problems here. One I can solve (an oversight on my part when updating the app to be Tyrannis 1.2 ready). The other problem seems to be a problem with the API itself (on your side).

Originally by: Dmitri Kreig
Hello!
Cached XML file for Asset list query contains only several hundreds of rows, and if i'm guessing correctly, 1 row = 1 item (stack), in wich case there should be several thousands of them.



You're right. 1 row should translate to 1 item (stack). If the XML itself is intact (=has a closing </eveapi> tag), that's all what the API returned. EWA downloads a XML file from the API, stores it first and then proceeds to process it. EWA never manipulates the XML file itself in any way. Please note though, that EWA's preview window of the cached XML files might shorten the file. To really see if the XML is complete and intact, export the cached asset API to a XML file and open it in a browser.

Quote:

App log entry for updating assets from API says: "Application Error: cEVEAssets:ParseXML->6, EVEWalletAware, Overflow". My OS is XP.



This is an oversight on my part. When updating EWA to by Tyrannis 1.2 ready, I missed to update one method, which causes the above error. This will be fixed in the next version. Not sure when I'll be able to release it, as I've just moved to a new flat and still have lots of stuff to do.

EWAAutoData suffers from this bug, too.

If you can't live without proper assets, try jEveAssets for asset management.

Dmitri Kreig
Posted - 2010.11.06 19:08:00 - [171]
 

I exported XML file, and opened it in Excel - and here they are, all 5+thousands entries with a proper /smthn closing.. you were right about it.

Since you are having RL issues, nevermind then, it is not a pressing matter. Hope it'll get working again eventually.. a very usefull tool, thank you for creating it Smile

Ulf Raben
Gallente
Posted - 2010.11.08 13:06:00 - [172]
 

Hello there Hel O'Ween
I have for some time enjoyed Your Tool .. which has been GREAT !
Now .. it doesnt show very much ..really a nuiscance
What can i .. who am a programing idiot do in order to
get back into Your indispensable tool ...
Could You please explain .. in the meticulous and thorough way
which has been the hallmark of Your tool
What I can do ?

Hel O'Ween
Men On A Mission
EVE Trade Consortium
Posted - 2010.11.08 19:52:00 - [173]
 

Sorry, Ulf, I don't get it. Could you please try rephrase your question "for dummies"?

I'm unsure if you meant to say that EWA did work for you, but not doesn't work anymore or if you want to get it working for you in the first place.

IF the first is the case, have you updated EWA and the database to the current version (menu "? -> Check for updates")? You need to do so in order for EWA to work with Tyrannis 1.2. Also there's a bug in the asset management (see the messages above yours), which I need to release a fix for.

Ulf Raben
Gallente
Posted - 2010.11.09 07:01:00 - [174]
 

Well the Basic Screen seems to work normally ..n as far as i know ive installed all there is to install ..BUT : as said above ...when i try to update my assets in order to see changes ..the manager only came up with some few items ..n incomplete as well as erratic ..so it is of no use . I very much would like to get back to normal as Your tool .. BY FAR ..is the BEST TOOL FOR TRADERS available in EVE .. its German thoroughness .. at its best ! Could U please give some directions what I must do

Hel O'Ween
Men On A Mission
EVE Trade Consortium
Posted - 2010.11.09 08:37:00 - [175]
 

Originally by: Ulf Raben
BUT : as said above ...when i try to update my assets in order to see changes ..the manager only came up with some few items ..n incomplete as well as erratic ..so it is of no use . Could U please give some directions what I must do


I already mentioned in my last message (and as discussed in the posts right above your post) that currently there's a bug in EWA which prevents it from displaying assets correctly. You need to wait until I have time to release the fix.

alex9066
Posted - 2010.11.09 22:12:00 - [176]
 

Hi there, i love this tool for eve, its helping me understand how to make a profit and keep tabs on everything market related on eve, but recently i have been having problems with it....

I've uninstalled the EWA and then tried to reinstall it but am getting an error message when trying to install it, the error message is as follows:error accessing database at C:\ProgramData\EVEWalletAware\Data\.

Any help would be appreciated as im feeling a little lost without my stats lol.

P.S. Im running windows 7 64 bit.

Alex

Hel O'Ween
Men On A Mission
EVE Trade Consortium
Posted - 2010.11.10 09:04:00 - [177]
 

Originally by: alex9066

I've uninstalled the EWA and then tried to reinstall it but am getting an error message when trying to install it, the error message is as follows:error accessing database at C:\ProgramData\EVEWalletAware\Data\.

Any help would be appreciated as im feeling a little lost without my stats lol.

P.S. Im running windows 7 64 bit.



Good that you mentioned it. Windows 7 (and I guess Vista as well, but I skipped it) does some strange things with folders (junctions). I'm still not too familiar with Windows 7, so I'm not 100% sure if the following is the right solution:

- Locate EWA's config file EVEWalletAware.ini. It should be located under "C:\USERS\ALL USERS\EVEWALLETAWARE\evewalletaware.ini". Please note that you might find 3 copies of the file, of which two or "pointers" to this location. Make sure you find the right one.

Open the file with a text editor. Locate a section called [Database]. Beneath that there should be two lines:
1) Connection=<stuff>
2) DatabasePath=<stuff>

Those lines should look like this (I intentionally word-wrapped the first line here to not break the forum's layout, make sure that you have it in one line):

[Database]
Connection=Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\DOCUMENTS AND SETTINGS\
ALL USERS\APPLICATION DATA\EVEWALLETAWARE\DATA\evewalletaware.mdb;User Id=admin;Password=;
DatabasePath=C:\DOCUMENTS AND SETTINGS\ALL USERS\APPLICATION DATA\EVEWALLETAWARE\DATA\


I'm not sure why Windows 7 causes this havoc, as I follow Window's guidelines as to how to retrieve system folders (storage path for application data).

Perhaps more versatile Windows 7 users can point out an easier/better way of making EWA behave right.

MailDeadDrop
Rage and Terror
Posted - 2010.11.10 17:59:00 - [178]
 

Perhaps you can use something like %AppData% and then run the value through something like wshShell.ExpandEnvironmentStrings() ?

MDD

MagnatDragon
Posted - 2010.11.10 19:13:00 - [179]
 

I have dont work this program!What me do?

Hel O'Ween
Men On A Mission
EVE Trade Consortium
Posted - 2010.11.10 21:08:00 - [180]
 

Originally by: MailDeadDrop
Perhaps you can use something like %AppData% and then run the value through something like wshShell.ExpandEnvironmentStrings() ?



As I wrote, I'm using an official API (SHGetFolderPath() with CSIDL_COMMON_APPDATA). Initially the path is written to the INI by the installer, which predates Vista. So, perhaps the installer has problems of figuring out the right path and/or updating the INI with the proper value.

EWA itself seems to run fine, once the path is correct in the INI.

Originally by: MagnatDragon

I have dont work this program!What me do?



Well, a good start is always to try to describe your problem and anything that happens (or not) as good and detailed as you can. From what you've wrtoe, I can't even tell if you can't get EWA to run at all or simply have no idea on how to use it, once you installed it ...


Pages: first : previous : ... 2 3 4 5 [6] 7 8 9 10 ... : last (15)

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only