open All Channels
seplocked EVE Technology Lab
blankseplocked TEA (v1.2.1) - Member Management Mod for SMF 2, TeamSpeak 3 and Jabber
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: first : previous : ... 2 3 4 5 6 7 8 [9] 10 : last (10)

Author Topic

Tes La
Amarr
Imperial Academy
Posted - 2011.07.24 08:11:00 - [241]
 

Thanx Temar!

Full check working correct! :)

2 words about TS integration... TEA working ONLY if TS running with mysql db?

Temar Radeik
Intergalactic Syndicate
Nulli Secunda
Posted - 2011.07.24 13:59:00 - [242]
 

Nope

TS DataBase Settings are Required for UniqueID Registration Method
you can use the Online Method with out any Database Access

Tes La
Amarr
Imperial Academy
Posted - 2011.07.26 09:10:00 - [243]
 

hmm...
Stage one:
1. Create "Query login" - done
2. Open telnet connection to query port of my TS3 serv - done
3. query auth - done
--------------------
Server accept connection, login\pass accepted and worked

Stage two:
1. Open TS TEA setting
2. Set "enable" - done
3. Set server name, port, query port, query login\pass from stage one - done
4. Press "save" - done
----------------------
No connection to server(server group not grabbed from server)

how to repair connection?

Temar Radeik
Intergalactic Syndicate
Nulli Secunda
Posted - 2011.07.26 16:33:00 - [244]
 

what error message do you get, it normally appears right at top of page above everything

Tes La
Amarr
Imperial Academy
Posted - 2011.07.27 17:12:00 - [245]
 

in error log -
some
Undefined index: minitype
Undefined variable: gl
Undefined index: tea_ts_info
Undefined index: tea_api
Undefined index: tea_userid
Undefined index: tea_charid

and
Invalid argument supplied for foreach() at line 166
in index.php?action=admin;area=tea;sa=ts;save and index.php?action=admin;area=tea;sa=ts

http://imageshack.us/photo/my-images/196/65396362.jpg/
^--- screenshot of TEA TS settings. "Groups to Monitor and Remove" are empty :( i cant create rule

Kilgarth
Posted - 2011.07.27 19:09:00 - [246]
 

So any updates on why TS roles are not being removed when a member leaves a corp?

Also, I dont believe the cron is working for SMF, either. If it helps, I am running php 5 and SMF 2.0RC5 on a windows server 2008 R2 server...

I have looked through the scripts and I see no issues with the code that would conflict with anything or cause it not to run the cron. I am thinking of just making my own script to run the cron every hour like I have for our killboard..

Any suggestions?

Princess Morenta
Minmatar
Republic Military School
Posted - 2011.07.30 01:38:00 - [247]
 

So for the cronjob you just have the php cli execute TEA_Cron.php? on a regular basis?

Mandy Moo
Posted - 2011.07.30 10:51:00 - [248]
 

Originally by: Princess Morenta
So for the cronjob you just have the php cli execute TEA_Cron.php? on a regular basis?


Yes just add a job to your crontab such as :

@hourly php /path/to/TEA_Cron.php

Which would run the script every hour on the hour

Bachtulgo
Minmatar
Posted - 2011.07.31 16:01:00 - [249]
 

Hello,
how or where can I fix the Copyright Symbol for TEA EvE API?
I run the SMF 2.0 under utf-8 and then I have this little bug in the Copyright.

Please visit your user settings to re-enable images.

Temar Radeik
Intergalactic Syndicate
Nulli Secunda
Posted - 2011.08.01 15:31:00 - [250]
 

thats supposed to be the c like above, you can find that on 2993 of the latest version (149)
you can try putting the html entitie in there instead

©

and let me know, id try it but i dont have an the issue as it is now

Bachtulgo
Minmatar
Posted - 2011.08.01 19:16:00 - [251]
 

Thanks

Yes I change it and now it is perfect. I change the Copyright symbol with the HTML tag.

Tes La
Amarr
Imperial Academy
Posted - 2011.08.06 14:19:00 - [252]
 

Hurrey! Im connect SMF to TS3 :)
but now i cant give user reg :(

[ERROR] invalid clientID

Temar Radeik
Intergalactic Syndicate
Nulli Secunda
Posted - 2011.08.06 14:52:00 - [253]
 

usually that means that there was a error trying to find the user
asuming u used online method, check the person is logged on ts and the name is the Same as shown before trying to register, its probably case sensitive too

Tes La
Amarr
Imperial Academy
Posted - 2011.08.07 05:48:00 - [254]
 

yep
im log in to TS with name fron TS-page of TEA and after what press "Change profile"
after that my nickname assign group

one question: then user left Alliance or API changed - i can runn full check for total user rights check and assign new group. But with TS - then im run full check- and user leave main group in SMF - his leaving TS grout too?

Temar Radeik
Intergalactic Syndicate
Nulli Secunda
Posted - 2011.08.07 15:00:00 - [255]
 

if you have the group ticked at top of the page and when you run the cron TEA_TS_Cron_Access.php it should be removed from TS

Temar Radeik
Intergalactic Syndicate
Nulli Secunda
Posted - 2011.08.14 15:22:00 - [256]
 

1.2.1 Released which ofc support SMF 2 GOLD
Please Note that there is no Support for RC5 etc as I didnt see the point of keeping support for RC when smf 2 is officially released now
altho most of you will already have it, if your dev version is below 154 then you should update to latest release / dev

PyroTech03
Caldari
Legion of Darkwind
Order of the Void
Posted - 2011.08.16 01:52:00 - [257]
 

This is nice. I'm looking to do a big switch over for forums and what not. Add EDK support and/or Jabber, and I would definatly switch to this and toss some ISK your way.

Temar Radeik
Intergalactic Syndicate
Nulli Secunda
Posted - 2011.08.16 02:02:00 - [258]
 

jabber is nearly done, the first supported jabber is openfire, more to come after
as for the killboard, well i have a mod thats for the kb side to manage access for posting kills/comments/admin area using SMF groups

PyroTech03
Caldari
Legion of Darkwind
Order of the Void
Posted - 2011.08.16 03:17:00 - [259]
 

I just logged, to say, I love you!

Really though, you have a link to your EDK/SMF mod? I would recommend possibly integrating the two as a toggle on/off part, as most people going this far will have a KB likely, and you could therefore take it farther to allow posting of KB into forums and whatnot even, since you know that the both would be present.

Add a mediawiki bridge to this (which I'm looking at those now) and you have yourself a full implementation of a corp/alliance communication network.

Should I just hold off on doing this until you have the next build up? or is it pretty easy to upgrade?

I'll be sure to send some ISK your way when the jabber stuff gets up and I get this running.

Mandy Moo
Posted - 2011.08.18 19:48:00 - [260]
 

Originally by: Temar Radeik
jabber is nearly done


Can't wait for this :D

Temar Radeik
Intergalactic Syndicate
Nulli Secunda
Posted - 2011.08.19 00:01:00 - [261]
 

people on the ingame mailing list were invited to the Beta, if interested send me a mail

Krusty McNugget
Nomads
Nulli Secunda
Posted - 2011.08.19 11:09:00 - [262]
 

Edited by: Krusty McNugget on 19/08/2011 11:10:20
BIG! thanks to Temar for making the jabber thing happen. :)

Got it up and running with temar's sweet voice in my ears..

Nulli forums, best test forums...

Make sure to be generous in your donations.. and im sure he will assist in setups for a small fee as well. ;)

Alicia Storm
Posted - 2011.08.20 07:17:00 - [263]
 

I have attempted to use ESAM and TEA, but when I got to the install part on my SMF 2.0 and 2.0 RC3 forum's, all Test's Pass, except for the 2nd Line: /Sources/Admin.php edit. It says to do the following:

Code: (Find) [Select]
),
),
'layout' => array(
'title' => $txt['layout_controls'],

Code: (Replace) [Select]
'tea' => array(
'label' => $txt['tea_tea'],
'file' => 'TEA.php',
'function' => 'ModifyTEASettings',
'icon' => 'tea.gif',
'subsections' => array(
'info' => array($txt['tea_info']),
'settings' => array($txt['settings']),
'rules' => array($txt['tea_rules']),
'ts' => array($txt['tea_ts']),
'checks' => array($txt['tea_checks']),
),
),
),
),
'layout' => array(
'title' => $txt['layout_controls'],


---------------------

But this edit does not work. It doesn't make the edit itself and I have tried setting the packages Folder and Admin file to permissions 777. When I have attempted to edit the file manually it literally stuffs up my forum from loading.

It is only this one area that does not pass, I have tried installing it anyway, but there are no options in the Configuration Menu "Features & Options" that has anything to do with this mod, no where to turn it on or off. I have looked at my own profile in and in settings there is the menu area's for the API and teamspaeak, but when I select them it says the mod is disabled.

Can someone please help me with this issue?

I have tried to use

TEA_1_2_1.tar.gz
TEA_1_2_1.zip
TEA-trunk.r155

and

esam_v1.4.2.tgz
esam_v1.4.2_avatar_fix.tgz
esam_v1.4.1.tgz

And I have tried using all of these versions on both the following forum versions:

SMF 2.0
SMF 2.0 RC3

I believe I am almost there, but I do not know why this will not work. I use the "Dark Mark" theme, but I have tried installing all these versions onto the many other Theme's I have installed and also the Default theme, and it is also the 1 piece that is not Passig the Test and considering it is Admin.php file, it is obvious why I do not have any options to turn it on or off or any other menu options for it in Features & Options.

Please help me if you can. Thank you very much.

Temar Radeik
Intergalactic Syndicate
Nulli Secunda
Posted - 2011.08.20 09:09:00 - [264]
 

well the latest TEA (all 3 u posted are the same) it only support SMF 2.0 (GOLD)
RC3 is old

as for ESAM it was made for SMF 1

chances are the mod if conficting with another mod, as in another mod makes a change and breaks the installer for my mod

if no mod is install you forum is prob corrupt (changes to code that shouldnt be there)
which would be from failed installs/uninstall etc

an easy fix is to get the large upgrade from smf site, extract on top of current forum
this will basicly remove all modifications, and set all mods as uninstalled (if any set installed)
u can ofc delete upgrade.php (if your already at this verion) and not run it

after that it should install fine

Alicia Storm
Posted - 2011.08.20 23:41:00 - [265]
 

Actually your advice was wrong, my web hosting service got it fixed in 5 minutes, and we didn't have to do anything you suggested, but the main thing is I got it working.

Glencore Ramskill
Posted - 2011.08.21 17:51:00 - [266]
 

I don't understand how I enable this mod. I have installed it. Checked under Admin -> Configuration - > Features and Options -> General and it is not there :|

Alicia Storm
Posted - 2011.08.21 23:13:00 - [267]
 

I actually found that when I installed it on SMF 2.0 not Gold, that the setting wasn't listed in Features and Options, it is at the far bottom of the Configuration Settings Menu, so look all the way down to the bottom. Thats all I seem to know about my Settings location.

Alicia Storm
Posted - 2011.08.21 23:48:00 - [268]
 

I need a little help setting up the Mods Settings. It is fully installed, I really don't need to worry about TS3 yet, but I added my Full Api key and selected a few ticked options and then it revoked my admin status, adding me as my character, how do I set up these settings so this doesn't happen??

Is there a guide that shows you what you should place exactly into RULES settings and SETTINGS pages, something that will explain some of the options there is to select? I know the API part where you add API key and User ID, but these parts are a little, well I may be stupid, but confusing as to what they do exactly?

Is a Valid Api required to Register?
Is Real name Locked to Characters
Is Getting an Avatar of a Character Enabled
Is Getting an Avatar Locked to Characters

and

Group Setting for Users with no API Group for Unknown Status


Lastly the settings on RULES page, at the bottom where it asks for

Create Rule:

Name:
Rule ID:
Main Group:

Condition link:

IS or ISNT:

Type:

Corp Name or ID:

Group:

Can someone help me as to what these settings do and how I should set them?

Or it may help even more if there was a guide out there that explained all these settings, so you can set them up correctly. Pls help in any part if you can, I do need help with this. Thank you heaps.

PyroTech03
Caldari
Legion of Darkwind
Order of the Void
Posted - 2011.08.22 07:11:00 - [269]
 

Edited by: PyroTech03 on 22/08/2011 07:22:53
I have been able to mess with this in a limited fashion on a test setup....everything is working fairly well.

But due to webhost not wanting to play nice with me or my TS3 host....i can't test fully deployed to my alliance.

So I'm looking into a server host and will hopefully have something up in a week or two. Until then, great job!

EDIT: one issue, it seemed to me, that the TS3 didn't want to acknowledge the alliance ticker tag #at# and neither did the openfire. It caught it and added it just fine in SMF though.

Elesil Daelwon Taranogas
Posted - 2011.08.25 14:44:00 - [270]
 

Hi@all

I have uploaded the mod and installed.
if I go without modifications it is not displayed.

But under Mod's installed it will appear.

and that is the message that is displayed.

Quote:
There are no modifications installed that have added any settings to this area yet.


I'm using smf 2.0

greeting


Pages: first : previous : ... 2 3 4 5 6 7 8 [9] 10 : last (10)

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only