open All Channels
seplocked Market Discussions
blankseplocked The Next EMMA thread. - 1.5.1.0 now available. Massive update.
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: first : previous : ... 9 10 11 12 [13] 14 15 16 17 ... : last (30)

Author Topic

Kazuo Ishiguro
House of Marbles
Posted - 2010.04.24 23:26:00 - [361]
 

Originally by: Lost Hamster
Originally by: Kazuo Ishiguro

After uninstalling 2005 and installing 2008 on windows 7 it was set to 'network login'. I suspect I might have avoided this if I'd attempted an upgrade, but I just wanted a clean install.


I doubt, as you can't have sql 2005, and 2008 next to each other. I don't think that during the install it gives you the option to upgrade. Rolling Eyes


True, I did get a message to that effect when using the default installer for 2008, but I think there's an option to do an upgrade if you look in a different part of the download site.

Ambo
I've Got Nothing
Posted - 2010.04.29 11:27:00 - [362]
 

Edited by: Ambo on 29/04/2010 11:27:18
Originally by: Imuran
Originally by: Lost Hamster
Ambo, I think it's the same as here:
http://www.eveonline.com/ingameboard.asp?a=topic&threadID=1180576&page=4#114
"There is an issue with contracts which are accepted for Corp.
They appear twice in the income statement, As it is registered for personal, and for corporation entry as well.

If TypeID=79 then the SWalletID needs to be changed from 1000 to 0
Then in the income statement it will only appear as a corp expense, not as personal. "



Yep its the income statement - but its not limited to contracts. I have one character that all he does is buy and sell on behalf of the corp

Report 1 Corporation only
Market Transactions 14,109,154,743

Report 2 Corporation and Character
Market Transactions 27,266,349,849

Note I have other characters that sell for the corp so report 2 is not double report 1 but its close



I FINALLY got some decent data for this and identified the problem.

The SQL query that returns the data for the income statement works by returning the sum of all journal entries that match the specified criteria. Those criteria being:

  • within a date range

  • having a specified journal type id

  • being linked to at least one of a list of characters and corps



The problem is that these entries are linked to both the corp and the character being included in the report and hence get double counted.

The solution to this is to change the query so that entries are only included for the character if they are NOT done on behalf of a corp as well.

i.e. A income statement report for just the character would not show any of the journal entries created by that character on behalf of the corp.

This seems right to me but since it's a change to an existing system I'd like to hear your thoughts, let me know if you think this would be a bad solution, etc.


For those interested, here's the details of the change required to the SQL query (the parts in green would be added):


SELECT @sumAmt = SUM(Journal.Amount)
FROM Journal
JOIN CLR_financelist_split(@accessParams) a ON(
(@type != 'revenue' AND ((Journal.SenderID = a.ownerID AND Journal.SCorpID = 0) OR
Journal.SCorpID = a.ownerID) AND (a.walletID1 = 0 OR (Journal.SWalletID = a.walletID1 OR
Journal.SWalletID = a.walletID2 OR Journal.SWalletID = a.walletID3 OR Journal.SWalletID = a.walletID4 OR
Journal.SWalletID = a.walletID5 OR Journal.SWalletID = a.walletID6))) OR
(@type != 'expense' AND ((Journal.RecieverID = a.ownerID AND Journal.RCorpID = 0) OR
Journal.RCorpID = a.ownerID) AND (a.walletID1 = 0 OR (Journal.RWalletID = a.walletID1 OR
Journal.RWalletID = a.walletID2 OR Journal.RWalletID = a.walletID3 OR Journal.RWalletID = a.walletID4 OR
Journal.RWalletID = a.walletID5 OR Journal.RWalletID = a.walletID6))) OR a.ownerID = 0)
WHERE ((Journal.Date > @startTime) AND
(Journal.Date <= @endTime) AND
(Journal.TypeID = @refType OR @refType = 0))



Lost Hamster
Hamster Holding Corp
Posted - 2010.04.29 16:01:00 - [363]
 

Personally I do not have problem with this. I get a more accurate report, what is important for me. And maybe I can use again corporation orders again. Cool

Mithril Ryder
Genstar Inc
Posted - 2010.05.02 03:49:00 - [364]
 

Hey, I just installed a new OS on a fresh hard dive, what do I need to do to move over EMMA and it's database to the new machine?

Ambo
I've Got Nothing
Posted - 2010.05.02 09:56:00 - [365]
 

Originally by: Mithril Ryder
Hey, I just installed a new OS on a fresh hard dive, what do I need to do to move over EMMA and it's database to the new machine?


Grab the installer
EMMA's data files are stored in '%appdata%/EMMA/Data'. You need to find what that location was on your old HD and take a copy of the files from there. (If you don't know where to start then just do a file search for 'EMMA Database.mdf')
Install EMMA.
Copy the data files into '%appdata%/EMMA/Data' (This dir won't exist unless you run emma first.)

You are then good to go.

Loney
CyberDyne R-D
Posted - 2010.05.02 15:27:00 - [366]
 

Here's the delema... perhaps you konw a solution or can fix it to work right?

I have a corporation that has assets market orders, Prodution orders, Etc. In this corp I have multiple characters that all do market order, Production order, etc on behalf of the corporation only...

When i enter all the API data into EMMA it seems to work right EXCEPT when trying to pull all the CORP data from each character. It ONLY shows the order from the character that i have the COPR checkbox check... and when i try to check more then one CORP checkbox it tells me ONLY ONE of the same corp can be checked.

Can you fix this or perhaps tell me what im doing worng? Anyone else having this issue?

Loney
CyberDyne R-D
Posted - 2010.05.02 15:37:00 - [367]
 

Im also pretty sure the above mention reason is way my market reports and NAV report are also messed up all the time.. Everything except for the most current REPort is ways in the RED... Here is a Monthly nav report for last 6 months... why is it like this? +25b, -875b, -1.4t, -989b, -1.22t, -1.01t

Why dose it not seem to caculate stuff right... I best its becasue it don't pull all the right orders, and stuff from all the API of the characters... again is this a different problem or the same as i mentioned above?

If you have more prolbem or need mroe info please ask. thanks

Brusvillis
Posted - 2010.05.02 20:58:00 - [368]
 

Yo!
i updated EMMA, and got it running. But my current problem is. I havent used EMMA in a long time, a year or so. So i didnt remember my user and password.
So when i make a new user, and give it my API info. It says that it already have that User ID. how do i remove the old user?!

Ive tried to delete the files in \data\ folder, and looked for more files in the \documents and settings\ folder, but there are no files in that folder connected to EMMA >_<
Ive uninstalled and reinstalled EMMA, but with no luck mr.Chuck!

any idea?! Smile

Thanks :D

Ambo
I've Got Nothing
Posted - 2010.05.03 06:11:00 - [369]
 

Originally by: Brusvillis
Yo!
i updated EMMA, and got it running. But my current problem is. I havent used EMMA in a long time, a year or so. So i didnt remember my user and password.
So when i make a new user, and give it my API info. It says that it already have that User ID. how do i remove the old user?!

Ive tried to delete the files in \data\ folder, and looked for more files in the \documents and settings\ folder, but there are no files in that folder connected to EMMA >_<
Ive uninstalled and reinstalled EMMA, but with no luck mr.Chuck!

any idea?! Smile

Thanks :D


If you don't mind losing your data then your best bet is just to uninstall and reinstall with the latest EMMA installer.

The only other way would be for me to send you the encoded for of a specific password and you then manually put that into the database using SQL management studio.


Originally by: Loney
Im also pretty sure the above mention reason is way my market reports and NAV report are also messed up all the time.. Everything except for the most current REPort is ways in the RED... Here is a Monthly nav report for last 6 months... why is it like this? +25b, -875b, -1.4t, -989b, -1.22t, -1.01t

Why dose it not seem to caculate stuff right... I best its becasue it don't pull all the right orders, and stuff from all the API of the characters... again is this a different problem or the same as i mentioned above?

If you have more prolbem or need mroe info please ask. thanks


Tbh, the NAV report has never worked as well as I would have liked, though yours does seem extra special.. It would certainly cause problems with it if there were orders, etc missing from the database.

The reason it's restricted to one corp being accessed by only one char is that if you have two char in the same corp and include corp data for both of them then you'd be getting the same data twice for no reason. I never realised that the corp orders API would only show corp order for that particular character.

I'll take a look and see if I can fix this without making too many changes to the way the API update works.

Dibsi Dei
Salamyhkaisten kilta
Posted - 2010.05.03 12:33:00 - [370]
 

My emma stopped working around february. Some problem with the database.
http://www.salamyhkaiset.org/kilta/ExceptionLog.txt

It has been sad to know emma hasn't been collecting my market journal since.Sad

Ambo
I've Got Nothing
Posted - 2010.05.03 17:00:00 - [371]
 

Originally by: Dibsi Dei
My emma stopped working around february. Some problem with the database.
http://www.salamyhkaiset.org/kilta/ExceptionLog.txt

It has been sad to know emma hasn't been collecting my market journal since.Sad


Damn, that looks nasty. Not seen anything like it before. Did a quick google but could find anything really useful. All I can suggest is either starting over with a fresh DB or further reading up on this issue online to see if you can find anything that might help.


Lost Hamster
Hamster Holding Corp
Posted - 2010.05.03 22:35:00 - [372]
 

Originally by: Dibsi Dei
My emma stopped working around february. Some problem with the database.
http://www.salamyhkaiset.org/kilta/ExceptionLog.txt

It has been sad to know emma hasn't been collecting my market journal since.Sad


Looking the exception, the LOG file for the database is corrupt, or it's on a wrong version.

Take a backup of the C:\USERS\user\APPDATA\ROAMING\EMMA\DATA\ directory.

Rename the C:\USERS\user\APPDATA\ROAMING\EMMA\DATA\EMMA DATABASE.LDF to
C:\USERS\user\APPDATA\ROAMING\EMMA\DATA\EMMA DATABASE.LDF.bak

Start an SQL Management console.
On the database section, right click: Attach
ADD

Select the: C:\USERS\user\APPDATA\ROAMING\EMMA\DATA\EMMA DATABASE.MDF file

In the lower section it will write that he can not found the LDF file.
Select the line, and press remove.

Then press OK.
It will create a new log file, and then the system should be able to open it.

When it has attached the database, then right click on the EMMA DATABASE and select Task -> Detach

When this is done, then in theory you should be able to start EMMA normally.
---------------------

It could be if you just rename the .LDF file and you can start up EMMA normally. I can not try that as I use a different connection method.

Dibsi Dei
Salamyhkaisten kilta
Posted - 2010.05.03 23:23:00 - [373]
 

Yea i think it was some auto-update that failed to download itself and somehow my database got corrupted.

Lost Hamster
Hamster Holding Corp
Posted - 2010.05.04 06:22:00 - [374]
 

Originally by: Dibsi Dei
Yea i think it was some auto-update that failed to download itself and somehow my database got corrupted.

I doubt, as the EMMA Database is a personal DB, which contains the transaction/Journal logs. So that can not be updated in the traditional way. (Just getting a new one and replace it)

Only the EVEData is updated this way.


Imuran
Zentor Industries
Posted - 2010.05.06 12:05:00 - [375]
 

Quote:
This seems right to me but since it's a change to an existing system I'd like to hear your thoughts, let me know if you think this would be a bad solution, etc.


Very much the right change for me

Ambo
I've Got Nothing
Posted - 2010.05.07 15:16:00 - [376]
 

1.4.2.1 BETA released


  • The eve-metrics price update has not worked for a long time. Turns out the URL to call had changed so I've updated this and it will now work correctly.

  • Removed the restriction that prevented you from changing the 'to' date when creating the item report.

  • Corrected a bug that caused journal entries for a corporation to be counted twice when creating an income statement report if the report included both the corporation in question and the character that performed the action leading to the creation of the journal entry. This also means that an income statement for a character will not include any journal entries created by that character on behalf of a corporation (unless that corporation is also included in the report - note for more detail on this, see here)

  • Corrected a bug that could cause EMMA to report the wrong amount of some assets. This was related to the user creating item exchange contracts.

  • When corporate orders are updated, EMMA will now check through all characters in the report group and update corporate orders for any character that is part of that corp. This is done because the corp orders API only returns corp orders created by the character making the request.




There are also some database changes to accommodate further improvement plans that I have. These are small but low level and touch on many areas so if you get any odd behaviour after the update then please let me know.

Loney
CyberDyne R-D
Posted - 2010.05.11 18:49:00 - [377]
 

Originally by: Ambo
1.4.2.1 BETA released


  • The eve-metrics price update has not worked for a long time. Turns out the URL to call had changed so I've updated this and it will now work correctly.

  • Removed the restriction that prevented you from changing the 'to' date when creating the item report.

  • Corrected a bug that caused journal entries for a corporation to be counted twice when creating an income statement report if the report included both the corporation in question and the character that performed the action leading to the creation of the journal entry. This also means that an income statement for a character will not include any journal entries created by that character on behalf of a corporation (unless that corporation is also included in the report - note for more detail on this, see here)

  • Corrected a bug that could cause EMMA to report the wrong amount of some assets. This was related to the user creating item exchange contracts.

  • When corporate orders are updated, EMMA will now check through all characters in the report group and update corporate orders for any character that is part of that corp. This is done because the corp orders API only returns corp orders created by the character making the request.




There are also some database changes to accommodate further improvement plans that I have. These are small but low level and touch on many areas so if you get any odd behaviour after the update then please let me know.

YEah... I will give it a go and let you konw if i find any more problems with the new version.. woot!

Lost Hamster
Hamster Holding Corp
Posted - 2010.05.11 20:22:00 - [378]
 

Originally by: Ambo
1.4.2.1 BETA released


In the last 4 days, I use it, without any issue. Very Happy Thanks Ambo!

Loney
CyberDyne R-D
Posted - 2010.05.12 07:02:00 - [379]
 

Originally by: Ambo
1.4.2.1 BETA released


  • When corporate orders are updated, EMMA will now check through all characters in the report group and update corporate orders for any character that is part of that corp. This is done because the corp orders API only returns corp orders created by the character making the request.




There are also some database changes to accommodate further improvement plans that I have. These are small but low level and touch on many areas so if you get any odd behaviour after the update then please let me know.


I see some more accurate numbers when generating income reports.. but when i click on the ORDERS tab it still only displays the corp orders for the persons slelected with the sorp tab.. and not all corp orders from all members. I also see duplicate orders from that same character..

IE i have one cahr that sells dreads... one that sells carriers, sone for mods, one for minerals... so I will only see one catagory of which ever has the corp tab selected.. and will not see the others... I will also still SEE 5 copes of the dreads sell orders or whater order i have checked...

Do i have to Delete the database and wipe it of all past data since i install the new 2.4.2.1 update? or am i still doing somethin wrong?

Ambo
I've Got Nothing
Posted - 2010.05.12 07:27:00 - [380]
 

Originally by: Lost Hamster
Originally by: Ambo
1.4.2.1 BETA released


In the last 4 days, I use it, without any issue. Very Happy Thanks Ambo!


Thanks, always good to know Smile

Originally by: Loney
Originally by: Ambo
1.4.2.1 BETA released


  • When corporate orders are updated, EMMA will now check through all characters in the report group and update corporate orders for any character that is part of that corp. This is done because the corp orders API only returns corp orders created by the character making the request.




There are also some database changes to accommodate further improvement plans that I have. These are small but low level and touch on many areas so if you get any odd behaviour after the update then please let me know.


I see some more accurate numbers when generating income reports.. but when i click on the ORDERS tab it still only displays the corp orders for the persons slelected with the sorp tab.. and not all corp orders from all members. I also see duplicate orders from that same character..

IE i have one cahr that sells dreads... one that sells carriers, sone for mods, one for minerals... so I will only see one catagory of which ever has the corp tab selected.. and will not see the others... I will also still SEE 5 copes of the dreads sell orders or whater order i have checked...

Do i have to Delete the database and wipe it of all past data since i install the new 2.4.2.1 update? or am i still doing somethin wrong?


You certainly shouldn't have to clear the database. I'll get some test data so that I can try and reproduce the issue. Hopefully then I can figure out what's going wrong.

Peri Phusis
Posted - 2010.05.22 06:40:00 - [381]
 

Edited by: Peri Phusis on 22/05/2010 06:44:00
Hi Ambo:

Running WindowsXP

Installed latest version and SQL Server 2008
Deleted SQLEXPRESS and changed login to local

However I receive an error message:

Problem downloading file 'summary.xml'
Unable to connect to the remote server

Then EMMA loads and API Update Status keeps flashing alternately "Updating" and "Overdue"
But I've waited for up to an hour and it still doesn't update

=====================================================================================
EXCEPTION REPORT
=====================================================================================
5/21/2010 3:18:42 PM Error - EveMarketMonitorApp.Common.EMMAEveAPIException - Problem retrieving data from Eve web service
Inner Exception: Unable to connect to the remote server
Stack Trace: at System.Net.HttpWebRequest.GetRequestStream()
at EveMarketMonitorApp.AbstractionClasses.EveAPI.GetXml(String url, String parameters)
Inner Exception: No connection could be made because the target machine actively refused it 127.0.0.1:5555
Stack Trace: at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
at System.Net.Sockets.Socket.InternalConnect(EndPoint remoteEP)
at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Int32 timeout, Exception& exception)
=====================================================================================
EXCEPTION REPORT
=====================================================================================
5/21/2010 3:18:57 PM Error - EveMarketMonitorApp.Common.EMMAException - Cannot find account ''
=====================================================================================
EXCEPTION REPORT
=====================================================================================
5/21/2010 3:19:28 PM Warning - EveMarketMonitorApp.Common.EMMAInvalidPasswordException - Incorrect password entered for account 'komusubi'
=====================================================================================
EXCEPTION REPORT
=====================================================================================
5/21/2010 3:20:43 PM Error - EveMarketMonitorApp.Common.EMMAEveAPIException - Problem retrieving data from Eve web service
Inner Exception: Unable to connect to the remote server
Stack Trace: at System.Net.HttpWebRequest.GetRequestStream()
at EveMarketMonitorApp.AbstractionClasses.EveAPI.GetXml(String url, String parameters)
Inner Exception: No connection could be made because the target machine actively refused it 127.0.0.1:5555
Stack Trace: at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
at System.Net.Sockets.Socket.InternalConnect(EndPoint remoteEP)
at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Int32 timeout, Exception& exception)


Thanks

Ambo
I've Got Nothing
Posted - 2010.05.22 06:49:00 - [382]
 

Looks like EMMA is not being allowed access to the internet. Try adding it to your list of firewall exceptions.
null

Peri Phusis
Posted - 2010.05.22 08:29:00 - [383]
 

Added to exceptions list but still having the same problem. Could it be because I am using a proxy server? My in-game browser doesn't connect to the Internet either....

Lost Hamster
Hamster Holding Corp
Posted - 2010.05.22 09:13:00 - [384]
 

Originally by: Peri Phusis
Added to exceptions list but still having the same problem. Could it be because I am using a proxy server? My in-game browser doesn't connect to the Internet either....

Is the proxy setting set up in internet explorer?

Peri Phusis
Posted - 2010.05.22 18:02:00 - [385]
 

control panel => internet options => connections => LAN Settings

I think I set up the Proxy in order to use port forwarding in BitComet. Rolling Eyes And removing the proxy solved both problems

Thanks everyone for your help!

Imuran
Zentor Industries
Posted - 2010.05.26 12:05:00 - [386]
 

ISK report working nicely now thanks

Also from Tyrannis Patch Notes

Wallet Journal should now support bigint refIDs

The API has been up for a bit today and my Journal download not showing any errors - first time for a long time.

I assume there will be a download when the datacomes available for the new transaction and items types


Ambo
I've Got Nothing
Posted - 2010.05.26 16:22:00 - [387]
 

Originally by: Imuran
ISK report working nicely now thanks

Also from Tyrannis Patch Notes

Wallet Journal should now support bigint refIDs

The API has been up for a bit today and my Journal download not showing any errors - first time for a long time.

I assume there will be a download when the datacomes available for the new transaction and items types




Woohoo! About time Smile

There will indeed be a data update once the tyrannis datadump is made available.

Ambo
I've Got Nothing
Posted - 2010.05.27 10:02:00 - [388]
 

1.4.3.0 Beta deployed.

This contains the updated database for Tyrannis.


Assuming no problems, I'll do a full deployment in a couple of days.

clixoras
Posted - 2010.05.30 09:04:00 - [389]
 

Questin Ambo.

Say i've got a few months worth of data for some trade chars. And i transfer one char to another account, i add this account ofcourse to emma. Will the 'old' data still be linked to the correct char (on a new account)?

Lost Hamster
Hamster Holding Corp
Posted - 2010.05.30 10:15:00 - [390]
 

Edited by: Lost Hamster on 30/05/2010 10:15:23
Originally by: Ambo
1.4.3.0 Beta deployed.

This contains the updated database for Tyrannis.



No issues so far.

Originally by: clixoras
Questin Ambo.

Say i've got a few months worth of data for some trade chars. And i transfer one char to another account, i add this account ofcourse to emma. Will the 'old' data still be linked to the correct char (on a new account)?


I think it will, I doubt that CCP gives a new CharID during a character transfer. And all transaction are linked to the CharID


Pages: first : previous : ... 9 10 11 12 [13] 14 15 16 17 ... : last (30)

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only