open All Channels
seplocked Market Discussions
blankseplocked The Next EMMA thread. - 1.5.1.0 now available. Massive update.
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: first : previous : ... 7 8 9 10 [11] 12 13 14 15 ... : last (30)

Author Topic

Ainnir Domhnal
Posted - 2010.03.20 15:03:00 - [301]
 


When I look at the Item Details, the Order tab shows zero movement for all my buy orders for all the reported periods (12 hours, 2 days, 7 days). The Transactions tab (on Item Details), and the Transactions window both show transactions against the buy orders, so there shoudl be some movement showing.

Anyone else see this? Is there a fix?

Ambo
I've Got Nothing
Posted - 2010.03.30 07:45:00 - [302]
 

Originally by: Ainnir Domhnal

When I look at the Item Details, the Order tab shows zero movement for all my buy orders for all the reported periods (12 hours, 2 days, 7 days). The Transactions tab (on Item Details), and the Transactions window both show transactions against the buy orders, so there shoudl be some movement showing.

Anyone else see this? Is there a fix?



If I remember rightly, the movement is for the specific order entry rather than an item type.

i.e. you may have sold other 250mm railguns within the time but if they did not come from your current 250mm railgun sell order then the movement columns will not show it.

Secks Trader
Posted - 2010.03.30 14:20:00 - [303]
 

Edited by: Secks Trader on 30/03/2010 19:34:21
I'm not sure exactly how to set up stations for all the station drop downs. Even if I enter the station name exactly into my item exchange contract it says it can't add because of station id (0). Anyone have any tips?

Edit: The solution was to hit enter after I hit typed the station name instead of just going to the next box. I will enter a bug report.

Grayclay
Caldari
The Arrow Project
Morsus Mihi
Posted - 2010.04.01 03:25:00 - [304]
 

Ambo, your right. If you don't get it the first time, you better bunker down for a fight.

1. Downloaded EMMA.
2. Installed EMMA.
3. Ran Emma. Crashed on startup, didn't get passed splash screen.
4. Installed SQL 2005.
5. Ran Emma. Crashed again.
6. Spend 4 days reinstalling, installing .net, sql and EMMA.
7. Finally find post to "run as admin". Emma starts.
8. Auto-updates for the first time. I create my account.
9. Get error message, "enable clr in SQL".
10. Dig through SQL configurations. Enable SQL.
11. Restart computer.
12. Run AMMA as admin. Error message "Problem during auto-login: Failed to update database "C:\Program Files (x86)\EMMA\DATA\EMMA DATABASE.MDF" because the database is read-only.
13. Go to file path. Uncheck "Read only" for database. No change.

I'm running windows 7 64 bit.

Just got this message:
See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
at EveMarketMonitorApp.GUIElements.Main.RefreshDisplay()
at EveMarketMonitorApp.GUIElements.Main.Login()
at EveMarketMonitorApp.GUIElements.Main.ControlPanel_OptionSelected(Object myObject, CPOptionSelectedArgs args)
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll
----------------------------------------
EveMarketMonitorApp
Assembly Version: 1.3.2.2
Win32 Version: 1.3.2.2
CodeBase: file:///C:/Program%20Files%20(x86)/EMMA/EveMarketMonitorApp.exe
----------------------------------------
System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
Enforcer
Assembly Version: 1.3.0.5
Win32 Version: 1.3.0.5
CodeBase: file:///C:/Program%20Files%20(x86)/EMMA/Enforcer.DLL
----------------------------------------
System.Configuration
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.ServiceProcess
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.ServiceProcess/2.0.0.0__b03f5f7f11d50a3a/System.Servic

Grayclay
Caldari
The Arrow Project
Morsus Mihi
Posted - 2010.04.01 03:52:00 - [305]
 

Sadly that last message got cut off and I lost it. This is the exception report.

EXCEPTION REPORT
=====================================================================================
3/31/2010 8:17:40 PM Error - EveMarketMonitorApp.Common.EMMADataException - Problem adding station to database.
Inner Exception: Failed to update database "C:\PROGRAM FILES (X86)\EMMA\DATA\EVEDATA.MDF" because the database is read-only.
Stack Trace: at System.Data.Common.DbDataAdapter.UpdatedRowStatusErrors(RowUpdatedEventArgs rowUpdatedEvent, BatchCommandInfo[] batchCommands, Int32 commandCount)
at System.Data.Common.DbDataAdapter.UpdatedRowStatus(RowUpdatedEventArgs rowUpdatedEvent, BatchCommandInfo[] batchCommands, Int32 commandCount)
at System.Data.Common.DbDataAdapter.Update(DataRow[] dataRows, DataTableMapping tableMapping)
at System.Data.Common.DbDataAdapter.UpdateFromDataTable(DataTable dataTable, DataTableMapping tableMapping)
at System.Data.Common.DbDataAdapter.Update(DataTable dataTable)
at EveMarketMonitorApp.DatabaseClasses.EveDataSetTableAdapters.staStationsTableAdapter.Update(staStationsDataTable dataTable)
at EveMarketMonitorApp.DatabaseClasses.Stations.AddStation(Int32 stationID, String stationName, Int32 solarSystemID, Int32 corpID)
=====================================================================================
EXCEPTION REPORT
=====================================================================================
3/31/2010 8:22:34 PM Error - EveMarketMonitorApp.Common.EMMAException - Problem loading main form.
Inner Exception: Object reference not set to an instance of an object.
Stack Trace: at EveMarketMonitorApp.GUIElements.Main.RefreshDisplay()
at EveMarketMonitorApp.GUIElements.Main.Login()
at EveMarketMonitorApp.GUIElements.Main.Main_Load(Object sender, EventArgs e)

This is all very unfortunate because EMMA is my favorite eve-wallet app. I have yet to find another one that can seriously compare (that works with my computer).

Ambo
I've Got Nothing
Posted - 2010.04.01 07:30:00 - [306]
 

Originally by: Secks Trader
Edited by: Secks Trader on 30/03/2010 19:34:21
I'm not sure exactly how to set up stations for all the station drop downs. Even if I enter the station name exactly into my item exchange contract it says it can't add because of station id (0). Anyone have any tips?

Edit: The solution was to hit enter after I hit typed the station name instead of just going to the next box. I will enter a bug report.


Thanks for the info. I'll look into it if I ever make any changes.

Originally by: Grayclay
12. Run AMMA as admin. Error message "Problem during auto-login: Failed to update database "C:\Program Files (x86)\EMMA\DATA\EMMA DATABASE.MDF" because the database is read-only.



Sorry to hear about the problems you're having. I've actually seen this error a few times on my own system (also Win 7 x64). Unfortunately, I have no idea how to resolve it, sometimes it's a problem and other times it isn't, just seems to be random from my experiences. If I was still working on EMMA then it's something I'd look at (along with improving the installation for Win 7) but at the moment I'm afraid it's not likely to change. Sad

Grayclay
Caldari
The Arrow Project
Morsus Mihi
Posted - 2010.04.01 15:43:00 - [307]
 

Well is there an older stable version I can look at? Or is this it?

Lost Hamster
Hamster Holding Corp
Posted - 2010.04.01 18:58:00 - [308]
 

Originally by: Grayclay
Well is there an older stable version I can look at? Or is this it?

Actually, I do not have any problem with the latest version.

Looking your error message: Could be that the EVEDATA file has a read-only attribute set?

Grayclay
Caldari
The Arrow Project
Morsus Mihi
Posted - 2010.04.01 21:28:00 - [309]
 

Ok, I had originally unchecked readonly from the Database file, but then I just unchecked read only for the entire folder and I think when the auto_update file was unchecked it started working. Everything is good now =)

Lost Hamster
Hamster Holding Corp
Posted - 2010.04.03 08:05:00 - [310]
 

From the previous topic:
Originally by: Business Bunny

...


Originally by: Torvz

...


You can try to manually update it:
Here is a description how


Laskin Veldstar
Gallente
The Scope
Posted - 2010.04.06 23:30:00 - [311]
 

Ack! I wish I'd known there was a Key Gen before following the instructions on the program and sending 100mil to Ambo who never responded...

Lost Hamster
Hamster Holding Corp
Posted - 2010.04.07 10:16:00 - [312]
 

Originally by: Laskin Veldstar
Ack! I wish I'd known there was a Key Gen before following the instructions on the program and sending 100mil to Ambo who never responded...

Originally it required a license, but all the new versions does not require a license anymore.
The keygen only exist if there is a problem with the licensing.

Laskin Veldstar
Gallente
The Scope
Posted - 2010.04.07 17:11:00 - [313]
 

The version I downloaded from the link on the main EMMA post in the Market Resources sticky thread only a couple weeks ago required it...

BUT... I just read the notes in the auto updater "Version 1.3.1.1 - 25th Sep 2009: Removed license key check.". I'm getting an error when I try to install the update telling me there is a missing .dll file and then I have to uninstall the program and reinstall it. This is why I haven't updated it yet... Should really put the latest version on the download page...

Probably no way of getting that 100mil back eh Ambo?

Ambo
I've Got Nothing
Posted - 2010.04.07 19:29:00 - [314]
 

Edited by: Ambo on 07/04/2010 19:28:57
I've sent back the 100 mil. Must have missed it coming in.

Durrel Gahanan
Amarr
Imperial Academy
Posted - 2010.04.08 00:23:00 - [315]
 

Thank's Ambo. Now I just have to figure out why I'm having trouble running the updated version.

Santana IV
Heavy Risk...
Posted - 2010.04.09 02:57:00 - [316]
 

Edited by: Santana IV on 09/04/2010 03:03:52
The updated version crashes, both right after it updates (Gives an error that EMMA is already running and can't complete update. Another dialog box pops up and says EMMA has finished updating.) and any time I try to run the .exe after it has updated.

I left EMMA at the default version, which works, but on the API Update Status Window, Transactions, Journal and Orders are highlighted red and read "Error". Was this fixed in the updates, and if not, is there something I'm doing wrong? Assets updates fine. If it was included in the updates, is there anything I can do to get EMMA to update without crashing?

I'm using 7 x64.

EDIT: I made a new group, added a character to it, and there's no more error message on the API Status window, they're all highlighted green. However, it's still the same problem as above, I have no Journal entries, Orders or Transactions listed, with any date or anything. My Assets, however, do show up. It's like there are errors, but they're not displayed.

Lost Hamster
Hamster Holding Corp
Posted - 2010.04.09 07:48:00 - [317]
 

Originally by: Santana IV

...


Your problem is that the version what you use, can not use the 64bit values what the API is giving back.
Solution: upgrade to the latest version.

If you have problem with the auto update, you can try to update it manually:
http://www.eveonline.com/ingameboard.asp?a=topic&threadID=1180576&page=8#240

Santana IV
Heavy Risk...
Posted - 2010.04.09 19:24:00 - [318]
 

I manually updated, but it crashes immediately after running the exe. It just seems the updated version doesn't work...

Lost Hamster
Hamster Holding Corp
Posted - 2010.04.09 22:53:00 - [319]
 

Originally by: Santana IV
I manually updated, but it crashes immediately after running the exe. It just seems the updated version doesn't work...

Anything in the Logging\ExceptionLog.txt ?

Imuran
Zentor Industries
Posted - 2010.04.10 12:42:00 - [320]
 

Hate to say this but I think there is a fairly big "issue" with the ISK report when working with a market group of multiple characters and a corporation resulting in doubling of some values

What I think is happening is that when you gather the journal enteries for the report you get them all for the character regardles if the transaction was on behalf of the corp and then again for the corp itself.

On straight buy/sell operations the impact is small as the marging remains the same but it does give a false impression on the amount of business you are doing.

I noticed it when I bought an item for the corp off contracts for 900 Million. It shows up in the report as 1.8Billion which sort of has an impact on the monthly profit/loss calculations.

Santana IV
Heavy Risk...
Posted - 2010.04.10 17:47:00 - [321]
 

Originally by: Lost Hamster
Originally by: Santana IV
I manually updated, but it crashes immediately after running the exe. It just seems the updated version doesn't work...

Anything in the Logging\ExceptionLog.txt ?


Yes, but I believe this is what you were referring to when you said the older version is incompatible with 64:

=====================================================================================
EXCEPTION REPORT
=====================================================================================
4/9/2010 2:15:55 PM Error - EveMarketMonitorApp.Common.EMMAException - Error when adding journal data from api
Inner Exception: Value was either too large or too small for an Int32.
Stack Trace: at System.Number.ParseInt32(String s, NumberStyles style, NumberFormatInfo info)
at EveMarketMonitorApp.AbstractionClasses.APICharacter.RetrieveJournal(CharOrCorp corc, XmlDocument fileXML, Int16 defaultWalletID)


This is repeated about 10 times in the log. Doesn't seem to be anything about the crash. Maybe it has something to do with SQL Server?

Mr Yakamura
Posted - 2010.04.13 13:32:00 - [322]
 

Edited by: Mr Yakamura on 13/04/2010 19:38:05
Dont know if this has been covered already, but tbh, i cba going through every post.

I had issues with installing and running EMMA and Windows 7.
Here is my fix.

1) Ensure all windows updates are installed.
2) Download and install SQL Express 2005
3) Install EMMA
3) Restart Windows
4) Download and install SQL Express 2005 service pack 3 (NOT THE 32bit VERSION)
5) Restart Windows
6) Try and open EMMA, if it opens, bonus, if not proceed to next step
7) Right click on EMMA.EXE and select 'troubleshoot compatability
8) Do not use recommended settings, do it manually when prompted
9) select Worked earlier and requires permissions boxes and continue
10) Select Windows Vists with service pack 2 and select run as administrator

Finish the troubleshooter and viola... worked perfectly for me.

Hope this helps.



P.S Your still going to have a problem with the autoupdater... grrrr

Khayos
Caldari
United Enterprise
Posted - 2010.04.13 18:08:00 - [323]
 

Hi all.

I just wanted to add my experience with this software in the hope it would maybe help some others out.

This is for my system:

Windows 7 Ultimate 32-bit (6.1, Build 7600)

1. Download EMMA
2. Download SQL Server 2005 Express Edition SP3 32 Bit 64 bit I used the 32 bit.
3. Install SQL Server 2005 Express Edition SP3
(Clicked the link that says = Add user to the user who is running the SQL Server Express installation program to the SQL Server System Administrator role. By default, users on Microsoft Windows Vista operating system are not members of the SQL Server System Administrator.)
4. Extract the downloaded EMMA zip file.
5. Right click and "Run as Admin" on the setup.exe file.
6. Follow directions and install.
7. Once EMMA is installed, reboot PC for good measure.
8. Open EMMA up in the program browser window and right click "Run as admin" and open.
9. Allow patcher to run (in my case allowing firewall rule for EMMA)
10. Restart and begin using.

Fault free experience.

I did all the above and setup took no more than 10 minutes.

I am now navigating all the fun new things I have never used before but think I should and need to learn. :-)

Regards,

Mr Yakamura
Posted - 2010.04.13 19:37:00 - [324]
 

Does anybody have a location I can download 'evedata.zip' from?

The following link does EXACTLY what the auto updater does... it gets to about 7% and stops.

http://dl.eve-files.com/media/corp/Ambo/EveData.zip

No idea why it does that... i just downloaded another file from the same site and it worked fine... its just THIS FILE!

Any help please?

Ambo
I've Got Nothing
Posted - 2010.04.15 15:33:00 - [325]
 

Originally by: Imuran
Hate to say this but I think there is a fairly big "issue" with the ISK report when working with a market group of multiple characters and a corporation resulting in doubling of some values

What I think is happening is that when you gather the journal enteries for the report you get them all for the character regardles if the transaction was on behalf of the corp and then again for the corp itself.

On straight buy/sell operations the impact is small as the marging remains the same but it does give a false impression on the amount of business you are doing.

I noticed it when I bought an item for the corp off contracts for 900 Million. It shows up in the report as 1.8Billion which sort of has an impact on the monthly profit/loss calculations.



Couple of questions:

Which report are you talking about? I think it's the income report but not sure.

You say the item was bought off contracts which makes me think that it must be the income report unless you've entered the contract manually?

Since you bought it, I'm assuming you've got a negative 900 mil entry?
As you bought it off your own corp, I'm assuming the corp has a positive 900 mil entry?

Is the above correct or do you have just one positive or negative 1800 mil entry?


Originally by: Santana IV
I manually updated, but it crashes immediately after running the exe. It just seems the updated version doesn't work...


Update is coming soon, will hopefully resolve this.

Originally by: Mr Yakamura
Dont know if this has been covered already, but tbh, i cba going through every post.

I had issues with installing and running EMMA and Windows 7.
Here is my fix.


Originally by: Khayos
Hi all.

I just wanted to add my experience with this software in the hope it would maybe help some others out.


Thank you both for the detailed instructions. Hopefully others will find them useful.

Originally by: Mr Yakamura
Does anybody have a location I can download 'evedata.zip' from?

The following link does EXACTLY what the auto updater does... it gets to about 7% and stops.

http://dl.eve-files.com/media/corp/Ambo/EveData.zip

No idea why it does that... i just downloaded another file from the same site and it worked fine... its just THIS FILE!

Any help please?


Try going to Settings -> other settings. Highlight eve-files in the list and press the delete key to leave just starfreeze. Quit out of EMMA and see if the update works this time.

Lost Hamster
Hamster Holding Corp
Posted - 2010.04.15 16:01:00 - [326]
 

Ambo, I think it's the same as here:
http://www.eveonline.com/ingameboard.asp?a=topic&threadID=1180576&page=4#114
"There is an issue with contracts which are accepted for Corp.
They appear twice in the income statement, As it is registered for personal, and for corporation entry as well.

If TypeID=79 then the SWalletID needs to be changed from 1000 to 0
Then in the income statement it will only appear as a corp expense, not as personal. "

Ambo
I've Got Nothing
Posted - 2010.04.16 09:03:00 - [327]
 

Edited by: Ambo on 16/04/2010 09:03:13
Bugger, I remember looking at that before and it wasn't quite as easy to fix as I'd hoped..

Version 1.4.1.3 BETA is now available.


  • Resolved issues around using EMMA on Vista/Windows 7. i.e. you no longer have to 'run as administrator'. Unfortunately, a side effect of this is that the auto-update process will no longer automatically restart EMMA after an update.

  • WARNING: The above change also means that database files are now stored in the application data location. If you want to backup data, view logs, etc then open an explorer window and type in '%appdata%'. Then go into the EMMA folder. The structure is then the same as before, database files in 'Data', logs under 'Logging', etc.

  • WARNING2: The database format has been updated from SQL 2005 to SQL 2008. This means that SQL Express 2005 can no longer be used. You must install SQL Express 2008 instead. For help on installing SQL Express 2008, please see below. If you are already using SQL 2008 then this change will not affect you. If you don't want to install SQL 2008 then simply cancel this update and then disable EMMA's automatic update feature in settings -> other settings. You can continue using EMMA for as long as you like though you will no longer recieve updates to the software or the database.

  • Added the 'Traded Items' list back in. This is accessible through Settings -> Traded Items. It controls which items appear in the item report, the auto-contractor and the item detail screen.

  • Corrected some bugs that could cause the item detail screen to crash if using the 'generate red placeholder' orders option or using the 'group by' options in the inventory section.

  • Corrected a bug that caused error messages on startup to appear behind the splash screen.

  • Modified SQL version checks to be more robust and to require SQL 2008 instead of 2005.



SQL Express 2008 installation notes:

Install SQL Express from here: http://www.microsoft.com/express/sql/download/

Hopefully it will just work but if it does not then try these quick fixes.

1) Ensure that the following setting is correct:
Start -> Programs -> SQL 2008 -> Config -> config manager.
SQL Server Services -> SQL Server (SQLEXPRESS) -> Properties -> Change login to use 'Local System'

2) Delete the following folder:
Windows Vista: C:\Users\[user]\AppData\Local\Microsoft\Microsoft SQL Server Data\SQLEXPRESS
Windows XP: c:\Documents and Settings\[user]\Local Settings\Application Data\Microsoft\Microsoft SQL Server Data\SQLEXPRESS

Duke Hamilton1
Gallente
Posted - 2010.04.16 10:42:00 - [328]
 

Link to the new beta version would be great. Not to sure where to look.

Duke Hamilton1
Gallente
Posted - 2010.04.16 11:35:00 - [329]
 

All good works perfectly and looking forward to using it in depth. Thanks for your efforts to create a excellent tool.

Ambo
I've Got Nothing
Posted - 2010.04.16 12:02:00 - [330]
 

Thanks, I hope it's useful. :)

Currently, I'm just providing these new versions through EMMA's auto-update system. Once I'm reasonably happy that there are no big problems with it, I'll build a new installer package, upload it to the usual places and provide links.

Version 1.4.1.4 BETA now available:


  • Fixed a problem that caused a crash when opening the auto add configuration within the traded items settings screen.



Pages: first : previous : ... 7 8 9 10 [11] 12 13 14 15 ... : last (30)

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only