open All Channels
seplocked Market Discussions
blankseplocked The Next EMMA thread. - 1.5.1.0 now available. Massive update.
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: first : previous : ... 6 7 8 9 [10] 11 12 13 14 ... : last (30)

Author Topic

Vested Interest
Posted - 2010.02.09 16:31:00 - [271]
 

Edited by: Vested Interest on 09/02/2010 16:31:13
I have 1315 unacknowledged orders currently. Can you suggest a means of exporting or dumping this entire list out to a CSV or something?


edit: page 10 is mine muahahaha

Ambo
I've Got Nothing
Posted - 2010.02.09 22:52:00 - [272]
 

If you have SQL express management studio (free download from microsoft) then you can just do an SQL query to grab the relevant data. Not sure if you can then export that to CSV or not though..

Give me a shout if you need a hand building the SQL query.

Ambo
I've Got Nothing
Posted - 2010.02.10 12:51:00 - [273]
 

1.4.0.0 is now on general release.

This just updates the data to Dominion 1.1.1.

Ruby Chase
Posted - 2010.02.10 18:01:00 - [274]
 

Originally by: Ambo
1.4.0.0 is now on general release.

This just updates the data to Dominion 1.1.1.


So where can I download the latest EMMA - sorry, the first page has a link to 1.3.something....

Ambo
I've Got Nothing
Posted - 2010.02.10 21:56:00 - [275]
 

Originally by: Ruby Chase
Originally by: Ambo
1.4.0.0 is now on general release.

This just updates the data to Dominion 1.1.1.


So where can I download the latest EMMA - sorry, the first page has a link to 1.3.something....


It will auto update when you run the program.

If it dosn't then check the auto update settings in Settings -> other settings.

Aeg Nora'lee
Gallente
EVE University
Ivy League
Posted - 2010.02.11 15:52:00 - [276]
 

Edited by: Aeg Nora''lee on 11/02/2010 15:56:24
I'm having an issue with EMMA (latest version but i never used it before) :

The reprocessor won't calculate any mineral value when i check some items for reprocessing. Thre right pane just stay blank.

I've also noticed that if i choose mineral in item values setting for an item then "show calc detail" the calculation will be reprocess value = 0.

All other stuff is working great, BRAVO for this piece of software, very helpful.


Ambo
I've Got Nothing
Posted - 2010.02.11 17:52:00 - [277]
 

Originally by: Aeg Nora'lee
Edited by: Aeg Nora''lee on 11/02/2010 15:56:24
I'm having an issue with EMMA (latest version but i never used it before) :

The reprocessor won't calculate any mineral value when i check some items for reprocessing. Thre right pane just stay blank.

I've also noticed that if i choose mineral in item values setting for an item then "show calc detail" the calculation will be reprocess value = 0.

All other stuff is working great, BRAVO for this piece of software, very helpful.




Thanks. Smile

I get the same problem with the latest release. I'll take a look and hopefully have a fix sometime tomorrow.

Ambo
I've Got Nothing
Posted - 2010.02.15 12:09:00 - [278]
 

1.4.0.1 is now available

This fixes the issue with the reprocessor.

Dariah Stardweller
Gallente
NO U111 Enterprises
Posted - 2010.02.15 21:33:00 - [279]
 

Edited by: Dariah Stardweller on 15/02/2010 22:04:10
Does EMMA work under windows 7 64 bit? Cause I just finished installing it but it crashes immediately...


Edit: it does if you don't forget to run it as an admin Laughing

Lord Delacroix
Amarr
Team Ice
Posted - 2010.02.19 17:38:00 - [280]
 

Originally by: Dariah Stardweller


Edit: it does if you don't forget to run it as an admin Laughing



Thank you! Very HappyVery HappyVery Happy

I spent 20 mins trying to figure out whats wrong and was about to write a long bawww post :D

thank you mr dev for this awesome program!

Ambo
I've Got Nothing
Posted - 2010.02.19 23:08:00 - [281]
 

Glad you like it.
Sorry about the Vista/Win 7 need to run as admin... I should really get around to fixing that sometime.

Sal Pheebu
Posted - 2010.02.22 00:33:00 - [282]
 

Originally by: Ambo
1.4.0.1 is now available



I've tried to find this update a few times but I can only find the 1.3.1.0 download at EveFiles and GoogleSource. My version of Emma gives me a "Problem downloading file 'summary.xml'. Invalid URI: The hostname could not be parsed." error when I try the auto-update.

I have the feeling I'm missing something obvious, would welcome enlightenment.

Love the tool!

Ambo
I've Got Nothing
Posted - 2010.02.22 08:29:00 - [283]
 

Originally by: Sal Pheebu
Originally by: Ambo
1.4.0.1 is now available



I've tried to find this update a few times but I can only find the 1.3.1.0 download at EveFiles and GoogleSource. My version of Emma gives me a "Problem downloading file 'summary.xml'. Invalid URI: The hostname could not be parsed." error when I try the auto-update.

I have the feeling I'm missing something obvious, would welcome enlightenment.

Love the tool!



The installer is 1.3.1.0 but it should update automatically.

Since it's having problems, try removing eve-files from the list of update locations (Settings -> other settings -> highlight eve-files and press delete key)

Ambo
I've Got Nothing
Posted - 2010.02.23 09:18:00 - [284]
 

I found a problem in that the database files had been uploaded with lower-case letters where they were previously upper-case. This was not a problem for eve-files but was for starfreeze. It's now been fixed so updating should be working correctly again.

SencneS
Rebellion Against Big Irreversible Dinks
Posted - 2010.03.10 23:28:00 - [285]
 

I've got an odd-ball feature I'd like to request...

A global "clear" from a certain date. My alt has changed a few corps over the last year and I came across something odd and went digging only to find that the data from a previous corp was getting mixed in the the current corp. Now I fixed this by manually going into the database with Management Studio and deleting the data but I thought it might be a good idea to request a "black out" date.

It would need to be from Group or Character level in which any record which has a time older then x is instantly ignored...

I know development has been frozen but if it fires up again it might be nice to have something like "only use data newer then x date" or something. Until then I'm happy to just go and delete historical data directly from the database.

Nero Farway
Posted - 2010.03.14 05:18:00 - [286]
 

Edited by: Nero Farway on 14/03/2010 07:55:37
Edited by: Nero Farway on 14/03/2010 06:29:46
Edited by: Nero Farway on 14/03/2010 06:02:01
I am on Win7 64bit.

I installed EMMA, no Problems installing it.

I started EMMA it crashes.

Edit:

I Started Virtualbox and booted WinXP.

I tried to install EMMA and had a problem installing... I needed to download .NETFramework.

I downloaded .NETFramework and had a problem installing... I needed Windows Installer 3.1 to install it.

I downloaded Windows Installer 3.1 and installed it.

I installed .NETFramework.

I Installed EMMA.

I had to download the SQL Server.

I tried to install the SQL Server and Virtualbox crashed.

While downloading the SQL Server I read the forums and found out I have to start EMMA as Administrator on Win7.

I started EMMA and had to download the SQL Server. That is what I am doing now.


Normally I would have given up at the point I had downloaded .NETFramework and it asks me to download just another thing to install the thing I need to install EMMA. And I even Think I was lucky having SP2. I think wihtout that I would have had to download way more stuff... If I didnt have a fast internet connection I would have given up even now that I came that far, this SQL file is 270 mb (including some SP3 stuff which I think I needed since I dont have SP3). Ppl with the FCKGW key cant just isntall an SP on WinXP, fortunately I fixed that some weeks ago, that would have been another reason to give up :P


Conclusion so far: Things have to be Changed. SQL should be included in the file and automatically installed as well as the "run as admin" thing should be fixed. Going to edit if I tried it in Win7 with installed SQL.


Edit2:

I installed the SQL Server on Win7 and started EMMA. It deactivated APi access because it couldnt connect to the server. Timeout should take longer since I had to tell my firewall to let it through at first (good thing is that this reminded me of deinstalling my firewall since I have my new router now :P ).

It updated and restarted and I had to create an account.

I did that and added a group.

An error occured.

I investigated a bit and since google is my friend I found out I have to manually enable "clr".

I did that and now it seems to work. Didn't try a lot of things so far but there were no more errors.

additional Conclusions:

The Timeout for the connection time to the server should be changed.

"clr" shouldn't have to be manually activated in order to use EMMA.


Thanks for the program, going to test it now. I will edit this post again if I find some more things to tell you (or I will start a new post if this one isn't the latest anymore then)


Edit 3:

The Orders Tab doesn't view any orders (even though I have lots of orders up). Sometimes I get an error when EMMA is trying to retrieve order information, sometimes its ok... but I never get any orders in the list.

Ambo
I've Got Nothing
Posted - 2010.03.14 08:27:00 - [287]
 

Originally by: SencneS
I've got an odd-ball feature I'd like to request...

A global "clear" from a certain date. My alt has changed a few corps over the last year and I came across something odd and went digging only to find that the data from a previous corp was getting mixed in the the current corp. Now I fixed this by manually going into the database with Management Studio and deleting the data but I thought it might be a good idea to request a "black out" date.

It would need to be from Group or Character level in which any record which has a time older then x is instantly ignored...

I know development has been frozen but if it fires up again it might be nice to have something like "only use data newer then x date" or something. Until then I'm happy to just go and delete historical data directly from the database.


I'll add it to the requested features list on google code.

Originally by: Nero Farway

Many installation issues



Sorry to hear about all your troubles. EMMA seems to install without issue most of the time. Unfortunately if it doesn't install fine then you tend to have a real fight on your hands.


Originally by: Nero Farway

Ppl with the FCKGW key cant just isntall an SP on WinXP, fortunately I fixed that some weeks ago, that would have been another reason to give up :P



Lol. Not surprisingly, I wouldn't change the program just because people with illegal copies of Windows can't get a pre-requesite installed. Razz

Originally by: Nero Farway

Conclusion so far: Things have to be Changed. SQL should be included in the file and automatically installed as well as the "run as admin" thing should be fixed. Going to edit if I tried it in Win7 with installed SQL


The reasons SQL is not included are:

1. Some people want the 2008 version of SQL express instead of 2005.
2. Some people need the x64 version, others need x84.
3. Some people want SQL with management tools, others don't.
4. Some people already have a standalone SQL server that they want to use.

Packaging all these different options into an installer is beyond my knowledge and would probably make the installer file huge.


You're right, the run as admin thing should be fixed. EMMA was developed on a Win XP machine and at the time, I did not have access to Vista. Win 7 was not even out.
In short, it would be non-trivial job to fix it and development has been suspended. The source code is freely available though so someone else could always pick it up.


Originally by: Nero Farway
The Timeout for the connection time to the server should be changed.

"clr" shouldn't have to be manually activated in order to use EMMA.


IMO the timeout is already long enough that it's annoying when the API is down. Just restarting EMMA isn't a big deal is it?
The alternative would be setting the timeout to 10 mins or something to give you enough time to fiddle with firewall settings and that would be REALLY annoying.

The CLR thing is actually mentioned in the readme file that comes with the installer. On x86 systems, it is activated automatically. On x64 systems, there is a bug that means that although EMMA can turn the clr flag on, it won't take effect until the machine is reset.


Really hope you find it useful after all the throughle you've gone to to get it working. If you have any other problems then let me know.

Nero Farway
Posted - 2010.03.14 14:27:00 - [288]
 

The orders Tab does now work. Seems like EVEMon used up the 1x request per hour. After having turned off EVEMon everything works fine.

There should be some kind of program sharing the API information to all Programs using it (like EFT, EVEMon, EMMA etc.)

However, so far I am satisfied with the program. Still getting some error on the Investment section but this desnt prevent it from working (at least the things I tried so far).

Going to write more when I find new things to tell you about.

Thanks for the program =)

PS: yeah that FCKGW thing was more like a joke so that it doesnt get too boring reading my lovely organized wall of text :P

Cyaxares II
Posted - 2010.03.14 15:09:00 - [289]
 

Originally by: Nero Farway
There should be some kind of program sharing the API information to all Programs using it (like EFT, EVEMon, EMMA etc.)

these programs exist: Linkage

Nero Farway
Posted - 2010.03.14 15:20:00 - [290]
 

Originally by: Cyaxares II
Originally by: Nero Farway
There should be some kind of program sharing the API information to all Programs using it (like EFT, EVEMon, EMMA etc.)

these programs exist: Linkage


Thanks.



Another question about EMMA:

Is there a way to show which buy orders have been fullfilled this day/in a set period of time?

Ambo
I've Got Nothing
Posted - 2010.03.14 20:52:00 - [291]
 

Originally by: Nero Farway

Is there a way to show which buy orders have been fullfilled this day/in a set period of time?


Not really. You'd just have to use the orders tab and sort by date (which I think it does by default anyway?)

Ares Farway
Posted - 2010.03.15 19:16:00 - [292]
 

Hey, I am the alt of Nero Farway.

Quick question: There is an option to import an old EMMA file. Is there also an option for exporting to a file which then can be used after a new installation of EMMA or on another PC?

Lost Hamster
Hamster Holding Corp
Posted - 2010.03.15 19:30:00 - [293]
 

Edited by: Lost Hamster on 15/03/2010 19:34:32
Originally by: Ares Farway
Hey, I am the alt of Nero Farway.

Quick question: There is an option to import an old EMMA file. Is there also an option for exporting to a file which then can be used after a new installation of EMMA or on another PC?


I do not see any reason why it should not work automatically the update. The EMMA database structure was changed only after the dominion release. And the program detects the old database.

And simply copy the files to the new machine and use it. It's not needed to export it out.

Ares Farway
Posted - 2010.03.15 21:51:00 - [294]
 

Edited by: Ares Farway on 15/03/2010 21:54:37
Originally by: Lost Hamster
Edited by: Lost Hamster on 15/03/2010 19:34:32
Originally by: Ares Farway
Hey, I am the alt of Nero Farway.

Quick question: There is an option to import an old EMMA file. Is there also an option for exporting to a file which then can be used after a new installation of EMMA or on another PC?


I do not see any reason why it should not work automatically the update. The EMMA database structure was changed only after the dominion release. And the program detects the old database.

And simply copy the files to the new machine and use it. It's not needed to export it out.



I am sure copying the database would work but just creating an import file is easier.

However, I got another question:

Why is it that I oftne get an error on journal update on one account while it does work for another one?


Edit: Is eve Central or Eve metrics more accurate for calculating the value for reports?

Lost Hamster
Hamster Holding Corp
Posted - 2010.03.15 22:16:00 - [295]
 

Originally by: Ares Farway

I am sure copying the database would work but just creating an import file is easier.


There is not really an import feature. Maybe you can count a SQL backup/restore as one. Very Happy

Originally by: Ares Farway

Why is it that I often get an error on journal update on one account while it does work for another one?


Because it is working on an another account. I used to updated manually one by one to reduce this kind of problems. But since version 1.3.2.2 it's working really good the auto download. I rarely get an error.
/Or maybe CCP did fix some stuff on the API server/

Originally by: Ares Farway

Edit: Is eve Central or Eve metrics more accurate for calculating the value for reports?

No idea. I only use the ISK statement as report.

If I'm looking for assets value, then I use Jassests.

Shuluman
Posted - 2010.03.17 07:02:00 - [296]
 

I have been trying to get this working but failed. I downloaded the 1.3.0.something install from the first page and everything went fine. SQL2005 express installed and i ran it for the first time as an administrator. It updated but failed on the database.

Now when i try to run it i get an EMMA has stopped working error with the following text. This happens if I run it as an administrator or as a normal account.

OS is Windows 7 32bit fully patched.

Description:
Stopped working

Problem signature:
Problem Event Name: APPCRASH
Application Name: EveMarketMonitorApp.exe
Application Version: 1.3.2.2
Application Timestamp: 4b506ceb
Fault Module Name: KERNELBASE.dll
Fault Module Version: 6.1.7600.16385
Fault Module Timestamp: 4a5bdaae
Exception Code: e0434f4d
Exception Offset: 00009617
OS Version: 6.1.7600.2.0.0.256.1
Locale ID: 2057

Read our privacy statement online:
http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
C:\Windows\system32\en-US\erofflps.txt

Any ideas or is there a 1.4 version of the installer available?

cheers

Ambo
I've Got Nothing
Posted - 2010.03.17 08:18:00 - [297]
 

Have you tried right clicking the exe and selecting 'run as administrator'?

Your getting a different error message from usual for that problem but that may resolve it anyway.

Ambo
I've Got Nothing
Posted - 2010.03.17 08:24:00 - [298]
 

Originally by: Lost Hamster
Originally by: Ares Farway

I am sure copying the database would work but just creating an import file is easier.


There is not really an import feature. Maybe you can count a SQL backup/restore as one. Very Happy



Afraid so. I was going to make an export function but I figured it was a waste of time considering you can just copy the database files around.

The only downside is that it becomes rather difficult to combine databases but that's not something that people usually want to do.

Originally by: Lost Hamster

Originally by: Ares Farway

Edit: Is eve Central or Eve metrics more accurate for calculating the value for reports?

No idea. I only use the ISK statement as report.

If I'm looking for assets value, then I use Jassests.



It's largely subjective, in theory, they're just different sources of exactly the same information. In practice I tend to find eve-metrics is slightly better but there isn't much in it.

Shuluman
Posted - 2010.03.17 08:52:00 - [299]
 

Originally by: Ambo
Have you tried right clicking the exe and selecting 'run as administrator'?

Your getting a different error message from usual for that problem but that may resolve it anyway.


Yep tried that :)

The odd thing is that i ahve it working on a different computer that also runs Win7. I remember having some trouble getting it working but i cant remember exactly how i fixed it. I think it was by installing an earlier version and upgrading from there rather than the latest one

cheers

Ainnir Domhnal
Posted - 2010.03.20 14:55:00 - [300]
 

For those who'd rather not run EMMA as administrator, try installing it in your own user file space (not c:\Program Files, but under c:\Users\<your user name>\... ) and installing it just for yourself (not for all users). If you do this it runs just as your userid using only your file space and doesn't require admin priviledges.

At least, this is working for me on Vista 32-bit.


Pages: first : previous : ... 6 7 8 9 [10] 11 12 13 14 ... : last (30)

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only