open All Channels
seplocked Market Discussions
blankseplocked The Next EMMA thread. - 1.5.1.0 now available. Massive update.
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: [1] 2 3 4 5 6 7 8 9 ... : last (30)

Author Topic

Ambo
I've Got Nothing
Posted - 2009.09.17 12:03:00 - [1]
 

Edited by: Ambo on 05/02/2011 09:29:12
Edited by: Ambo on 06/10/2010 10:17:49
Edited by: Ambo on 23/07/2010 14:42:44

Due to me being unable to change Maestro's posts, I've decided it's best to start a new thread for all things EMMA related.

The previous one is here.


NEW: details on 1.5.1.0


The latest installer is available from google code (SHA1 Checksum: 0047175b37813b11a7ee481a4f9ec6b3b9941ee0)

Current status: Active(ish).


If you get any problems then feel free to report them here, through the google code issues tracker or directly to me - [email protected]


The sourcecode is also available through google code for those who are interested in building on it.

If you're a developer and want to help with the project then let me know.

Martow
Pineal Squeegee
Posted - 2009.09.19 12:01:00 - [2]
 

It seems like the trial code is enabled in this version again. Was that intentional?

Loaby
Amarr
Imperial Forces
Posted - 2009.09.19 12:02:00 - [3]
 

after the update yesterday the auto-contractor stucks.

i tried different settings for the cargo amount to let the contractor run over that specific "stucking"-station but then it stucks at another station.

any ideas?

No Profit
Posted - 2009.09.19 12:15:00 - [4]
 

Originally by: Martow
It seems like the trial code is enabled in this version again. Was that intentional?


No, that was not the intention. I can't look at it where I am right now so will have to wait for monday I'm afraid.

Maestro Del'Tirith
Space Exploration
Forward Motion Industries
Posted - 2009.09.19 12:27:00 - [5]
 

Ambo - did you check in your changes to google code? I can see about adjusting late tonight or Sunday.

Ambo
I've Got Nothing
Posted - 2009.09.19 12:38:00 - [6]
 

Originally by: Loaby
after the update yesterday the auto-contractor stucks.

i tried different settings for the cargo amount to let the contractor run over that specific "stucking"-station but then it stucks at another station.

any ideas?


I didn't touch the auto contractor code so no idea what's going on there.

It seems like some of the changes included in the last release must not have been committed to the google code repository.

Ambo
I've Got Nothing
Posted - 2009.09.19 12:44:00 - [7]
 

Originally by: Maestro Del'Tirith
Ambo - did you check in your changes to google code? I can see about adjusting late tonight or Sunday.


Yeah, all my latest changes are in there. Glad to see you're still around. Smile

Maestro Del'Tirith
Space Exploration
Forward Motion Industries
Posted - 2009.09.19 12:46:00 - [8]
 

Busy but I try to check in on occasion - I'll see if I can resolve the trial piece in the update tonight or tomorrow.

clixoras
Posted - 2009.09.20 00:50:00 - [9]
 

Originally by: Loaby
after the update yesterday the auto-contractor stucks.



was the beta released? i didnt see an (auto)update. (earlier update worked automatically so i assumed this update was also automatic). Do i have to install in manually?

Ambo
I've Got Nothing
Posted - 2009.09.20 06:36:00 - [10]
 

Originally by: clixoras
Originally by: Loaby
after the update yesterday the auto-contractor stucks.



was the beta released? i didnt see an (auto)update. (earlier update worked automatically so i assumed this update was also automatic). Do i have to install in manually?


Currently the update to 3.1.1.0 is only available as a beta. The main version is still the previous one. (i.e. 3.1.0.6 I think)

Maestro Del'Tirith
Space Exploration
Forward Motion Industries
Posted - 2009.09.20 19:24:00 - [11]
 

I poked around the code, and I can't see how or why the requirement for the key would have been re-added. The assembly which handles the key authentication is not referenced, and the previous points in the code which had the authorization check are not in there. Are you sure it wasn't a bad build/update?

Ambo - just a thought, but I think something that would really help is a new 'from scratch' build for download so that updates aren't required to disable the check. I attempted to do this at one point, but the setup project to build the installer went to the dogs with the upgrade to VS 2008.

Ambo
I've Got Nothing
Posted - 2009.09.21 07:24:00 - [12]
 

Originally by: Maestro Del'Tirith
I poked around the code, and I can't see how or why the requirement for the key would have been re-added. The assembly which handles the key authentication is not referenced, and the previous points in the code which had the authorization check are not in there. Are you sure it wasn't a bad build/update?

Ambo - just a thought, but I think something that would really help is a new 'from scratch' build for download so that updates aren't required to disable the check. I attempted to do this at one point, but the setup project to build the installer went to the dogs with the upgrade to VS 2008.


Really? I build a new setup project from 2008, it's linked in the first post in this thread.

Also, I've checked both my code and the google code browser and the license check is in there in both cases. I think you must have forgotten to commit your changes after removing the check?

Loaby
Amarr
Imperial Forces
Posted - 2009.09.21 15:40:00 - [13]
 

ambo, the nav report stops somewhere in the middle of the process. i can live with that but i am curious what this time limit notification (zeitlimit überschritten, blabla) means

Ambo
I've Got Nothing
Posted - 2009.09.21 18:14:00 - [14]
 

Originally by: Loaby
ambo, the nav report stops somewhere in the middle of the process. i can live with that but i am curious what this time limit notification (zeitlimit überschritten, blabla) means


I *think* that happens because the program detects an infinite loop and bails out of it. Could well be something totally different though.

I'm hoping we'll have these problems straightened out soon.

EyeCeeYou
Posted - 2009.09.22 04:52:00 - [15]
 

Hi - Thanks for all your work!

I tried installing v.1.3.1.0 tonite. Install seemed to work OK.

On first boot, it said I needed to install SQL (and gave me a link - nice!).

So, I did. But since I'm on a Vista 64 bit, I installed the 64 bit version.

After installing SQL, I tried to run application. It went further this time, but dropped out with an error message:

Quote:
There was a problem validating your installation. Requested registry access is not allowed.


Is this a known issue? Any suggestions??? Thanks!

Ambo
I've Got Nothing
Posted - 2009.09.22 07:14:00 - [16]
 

Originally by: EyeCeeYou
Hi - Thanks for all your work!

I tried installing v.1.3.1.0 tonite. Install seemed to work OK.

On first boot, it said I needed to install SQL (and gave me a link - nice!).

So, I did. But since I'm on a Vista 64 bit, I installed the 64 bit version.

After installing SQL, I tried to run application. It went further this time, but dropped out with an error message:

Quote:
There was a problem validating your installation. Requested registry access is not allowed.


Is this a known issue? Any suggestions??? Thanks!


The original application checked the registry to see if you had a valid license key for EMMA. Sounds like your user account does not have read access to the relevant area of the registry. (HKey local machine/Software/)

However, this check was actually removed in a previous version, we've just reintroduced it by mistake in this one. Hopefully there will be an update soon to correct the problem.

ingenting
Garoun Investment Bank
Posted - 2009.09.22 16:48:00 - [17]
 

still using that god-awful DB?

Lost Hamster
Hamster Holding Corp
Posted - 2009.09.22 18:41:00 - [18]
 

Originally by: ingenting
still using that god-awful DB?

If you mean MS-SQL, then yes. Very Happy
It's not that bad. :) I like it.

Ambo
I've Got Nothing
Posted - 2009.09.22 19:26:00 - [19]
 

Originally by: ingenting
still using that god-awful DB?


Well I'm not going to change it. That would be a huge job and I've explained my preference for MS SQL several times in the past. If you'd like to take the source code and make it work with another DB, then feel free. Very Happy

ingenting
Garoun Investment Bank
Posted - 2009.09.22 22:56:00 - [20]
 

Originally by: Lost Hamster
Originally by: ingenting
still using that god-awful DB?

If you mean MS-SQL, then yes. Very Happy
It's not that bad. :) I like it.
not that bad for XP, try anything else and... KABOOM :P

Currently I lack the skills to do that, Ambo Laughing

Lost Hamster
Hamster Holding Corp
Posted - 2009.09.23 07:53:00 - [21]
 

Originally by: ingenting
not that bad for XP, try anything else and... KABOOM :P


I don't know, I managed to install it anywhere on windows platform,
If you want it on linux, then a vmware will help you, to install an OS. ugh

Ps: and yes.. I'm a IT-pro, so it's not a big deal for me. Cool

Ambo
I've Got Nothing
Posted - 2009.09.24 07:11:00 - [22]
 

Maestro, could you commit your changes?

I can then build the release files for a new version.

Ambo
I've Got Nothing
Posted - 2009.09.25 15:09:00 - [23]
 

Beta 1.3.1.1 has now been released:

License check has been removed again.
Corrected a spelling mistake in reprocessor screen
Fixed a bug that caused item exchange contracts to always be created with the current date/time regardless of what the user entered.


Let me know any problems and hopefully I'll get a full release out soon.

Lost Hamster
Hamster Holding Corp
Posted - 2009.09.25 15:36:00 - [24]
 

There is a bug from the perv. versions that when you have a contraband entry in the journal, then the income statement drops an exception.

Cannot find specified row and column in the report.
Row: Expenses Contraband fine.
:Column: Column 0

Sal Pheebu
Posted - 2009.09.25 16:36:00 - [25]
 

Originally by: Ambo

If you have an older version of EMMA that requires a key and do not want to update for some reason then here is the official key generator


Hi Ambo,

I'm new to EMMA and loving it. I've got an older version that still requires a key, and would rather wait until the next full release rather than try the beta (since my current version is working perfectly for me).

Unfortunately, it doesn't look as though the Key Gen you refer to above is still in your directory at EVE Files. Any chance you could take another look at that and get it up there?

Say in the next three days...before my version of EMMA expires... Wink

Keep up the good work!
Sal

Ambo
I've Got Nothing
Posted - 2009.09.25 16:45:00 - [26]
 

Originally by: Sal Pheebu
Originally by: Ambo

If you have an older version of EMMA that requires a key and do not want to update for some reason then here is the official key generator


Hi Ambo,

I'm new to EMMA and loving it. I've got an older version that still requires a key, and would rather wait until the next full release rather than try the beta (since my current version is working perfectly for me).

Unfortunately, it doesn't look as though the Key Gen you refer to above is still in your directory at EVE Files. Any chance you could take another look at that and get it up there?

Say in the next three days...before my version of EMMA expires... Wink

Keep up the good work!
Sal


Oops, I accidentally deleted a load of stuff off eve-files the other day. Thought I'd got it all back but looks like I missed one!

I'll have it available again shortly.

Originally by: Lost Hamster
There is a bug from the perv. versions that when you have a contraband entry in the journal, then the income statement drops an exception.

Cannot find specified row and column in the report.
Row: Expenses Contraband fine.
:Column: Column 0



Thanks, I'll take a look at that at some point.

FX Engineer
Stir Crazy Research and Manufacturing
Posted - 2009.09.27 05:44:00 - [27]
 

Ambo,

This sounds like a really nice program to use to easily analyze the profitability of my trades, but I am unable to get the program to run. I have Vista Ultimate (32bit version). When I double click the application to run, it momentarily pops up then totally crashes.

Any recommendations?

Ambo
I've Got Nothing
Posted - 2009.09.27 06:34:00 - [28]
 

Originally by: FX Engineer
Ambo,

This sounds like a really nice program to use to easily analyze the profitability of my trades, but I am unable to get the program to run. I have Vista Ultimate (32bit version). When I double click the application to run, it momentarily pops up then totally crashes.

Any recommendations?


In the EMMA folder, there should be another folder called 'logging' in there will be a file called ' exceptionlog.txt'. If you could send me this ([email protected]) then that might give me some more information about what's going on.

Chribba
Otherworld Enterprises
Otherworld Empire
Posted - 2009.09.27 18:58:00 - [29]
 

While I have yet to see a fake-EMMA file on EVE-Files, a friendly suggestion to Ambo would to include MD5 hash-sums in the OP (used for those who indeed are paranoid) to ensure the content of the files downloaded.

EVE-Files will present you with a MD5-sum of the file downloaded, if this hash does not match the downloaded content, something isn't right and might be an advice to ensure the content being correct.

A good MD5 checker for windows can be found here.

This will probably never be an issue, but no harm in the extra info.

Keep up the good work Ambo.

/c

Ambo
I've Got Nothing
Posted - 2009.09.27 21:13:00 - [30]
 

Thanks Chrib, good idea. I'll add the info soon.


Pages: [1] 2 3 4 5 6 7 8 9 ... : last (30)

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only