open All Channels
seplocked Ships and Modules
blankseplocked pyfa - Python fitting assistant v0.8 - Dominion 1.1.1
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: first : previous : ... 2 3 4 5 [6] 7 8 9 10 ... : last (13)

Author Topic

Lan Staz
Posted - 2009.08.30 22:57:00 - [151]
 

Oh no - VirtualBox and WinXP are getting close to vanishing from my PCs !

Very Happy

Keep up the good work Sakari.

Ancy Denaries
Posted - 2009.08.31 04:42:00 - [152]
 

Originally by: Lan Staz
Oh no - VirtualBox and WinXP are getting close to vanishing from my PCs !

Very Happy

Keep up the good work Sakari.
Haha! I felt the same way! Now if I could only get Evemon running, or gtkEVEmon gets up to spec...

Kazacy
Caldari
Silent Overwatch
S I L E N T.
Posted - 2009.08.31 07:43:00 - [153]
 

I am sorry to say but i found a bug.
When i fit a medium unstable neutralizer on a pilgrim the fit disappears entirely; i tried even with the latest git snapshot and the bug still remain.

Sakari Orisi
BIG
Gentlemen's Agreement
Posted - 2009.08.31 07:50:00 - [154]
 

Edited by: Sakari Orisi on 31/08/2009 08:02:39
Originally by: Kadesh Priestess
I don't see speed, signature and some other attributes of the ship. As far as i understand these are 'missing effects', right?

Also, for present effects - e.g. DPS. When i overheat turret overall setup DPS is not increased. Is overheat another kind of missing effect?

Signature radius and speed can be seen on the bottom of the right pane, in the "Misc" section.
Other things can be found by right clicking on the fitting pane and hitting "View Ship Stats"

What turrets aren't working with overheating exactly ? they *should* be working.

NB: there should be no missing effects in pyfa anymore, anything not working is a bug.

EDIT: ok, I found the bug with overloading and fixed it, thanks for reporting

Originally by: Kazacy
I am sorry to say but i found a bug.
When i fit a medium unstable neutralizer on a pilgrim the fit disappears entirely; i tried even with the latest git snapshot and the bug still remain.


This was already fixed on the latest git somewhere yesterday.

Kadesh Priestess
Scalding Chill
Posted - 2009.08.31 08:40:00 - [155]
 

Thanks, overheat is properly taken into account with latest commits.
Originally by: Sakari Orisi

Signature radius and speed can be seen on the bottom of the right pane, in the "Misc" section.
...
NB: there should be no missing effects in pyfa anymore, anything not working is a bug.
Okay, got it. For me half of these attributes equal zero, i'll play with these a bit and report to trac.

Kazacy
Caldari
Silent Overwatch
S I L E N T.
Posted - 2009.08.31 08:48:00 - [156]
 

My mistake; srry it was not the lates git; thx alot for the support

Kadesh Priestess
Scalding Chill
Posted - 2009.08.31 09:09:00 - [157]
 

Edited by: Kadesh Priestess on 31/08/2009 09:34:20
Got a question regarding trac.

I filled several tickets (user darkfenx) and added myself to cc list in some of them, but i do not get any email notifications, even for issues that have been changed. Does trac have some other form of notifications or it's my email provider problem?

edit: aha, filled couple of fields in preferences, let's see if this helps.

Sakari Orisi
BIG
Gentlemen's Agreement
Posted - 2009.08.31 11:21:00 - [158]
 

Edited by: Sakari Orisi on 31/08/2009 11:23:07
Originally by: Kadesh Priestess
Edited by: Kadesh Priestess on 31/08/2009 09:34:20
Got a question regarding trac.

I filled several tickets (user darkfenx) and added myself to cc list in some of them, but i do not get any email notifications, even for issues that have been changed. Does trac have some other form of notifications or it's my email provider problem?

edit: aha, filled couple of fields in preferences, let's see if this helps.

the cc field takes a username, it seems you filled an email directly

EDIT: however, as you're the creator of the tickets, you should get an email to the email adress set in your preferences anyway

Kadesh Priestess
Scalding Chill
Posted - 2009.08.31 11:50:00 - [159]
 

Edited by: Kadesh Priestess on 31/08/2009 12:05:33
Originally by: Sakari Orisi
the cc field takes a username, it seems you filled an email directly
CC field wasn't filled automatically. When i had no email in preferences - trac suggested my username as default value to add into cc, after i filled email - it suggests to add an email instead.

Originally by: Sakari Orisi
EDIT: however, as you're the creator of the tickets, you should get an email to the email adress set in your preferences anyway
Exactly, i've used to this behaviour with other bug tracking systems. Will try to switch to another email server.

Yet another couple of questions:
1) When you resolved something in a way that's not 100% correct from my perspective, do you want us to open new ticket or reopen resolved one (with corresponding comments about what needs to be corrected)?
2) Only IRC room? Again, it's been long since i didn't use IRC. Could anybody offer good jabber => IRC transport?

Sakari Orisi
BIG
Gentlemen's Agreement
Posted - 2009.08.31 12:29:00 - [160]
 

Edited by: Sakari Orisi on 31/08/2009 12:29:13
Originally by: Kadesh Priestess
1) When you resolved something in a way that's not 100% correct from my perspective, do you want us to open new ticket or reopen resolved one (with corresponding comments about what needs to be corrected)?

Reopening is the right thing to do in that case.

EDIT: spelling

Sakari Orisi
BIG
Gentlemen's Agreement
Posted - 2009.08.31 18:10:00 - [161]
 

I'd like to announce the release of pyfa 0.3.8, this is strictly a bugfix release.

Kadesh Priestess
Scalding Chill
Posted - 2009.09.01 10:18:00 - [162]
 

Thx for update, at last it became completely usable when running on linux box with python 2.5 Razz

Sakari Orisi
BIG
Gentlemen's Agreement
Posted - 2009.09.01 17:18:00 - [163]
 

Originally by: Kadesh Priestess
Thx for update, at last it became completely usable when running on linux box with python 2.5 Razz

Ya, sorry for not noticing that bug earlyer, I don't use python 2.5 myself :(

DZ Cielo
Argon .Inc
STR8NGE BREW
Posted - 2009.09.01 17:19:00 - [164]
 

I love this, find it much better than EFT, simply for the fact i can get numbers to compare tank types, like hmm if i armor tank my reppers can give me 78hps, if i shield boost i can get 71hps but my resists are higher.

awesome program :D

Attiladehun
Gallente
Fire Mandrill
Posted - 2009.09.02 11:14:00 - [165]
 

Edited by: Attiladehun on 02/09/2009 11:17:25
Hey Sakari,

Can you check out the T3 cruisers?
I tried a setup of the loki with "Adaptive Augmenter" which gives a bonus of 5% resist per lvl on armor.
When i set my skills to lvl5 or lvl0 nothing changes on the resists. Only on hardeners the situation changes.
Log:
mainWindow.py:443: GtkWarning: Don't know color `<GdkColor at 0x1866f50>'
Traceback (most recent call last):
File "gui\mainWindow.pyo", line 1531, in itemsClicked
File "gui\mainWindow.pyo", line 1221, in addItem
File "gui\mainWindow.pyo", line 549, in fittingChanged
File "model\fitting.pyo", line 574, in calculateModifiedAttributes
TypeError: unsupported operand type(s) for +: 'exceptions.KeyError' and 'str'
library.zip\gui\mainWindow.py:443: GtkWarning: Don't know color `<GdkColor at 0x1873000>'
library.zip\gui\mainWindow.py:443: GtkWarning: Don't know color `<GdkColor at 0x186f090>'
library.zip\gui\mainWindow.py:443: GtkWarning: Don't know color `<GdkColor at 0x186f000>'

Kadesh Priestess
Scalding Chill
Posted - 2009.09.02 12:17:00 - [166]
 

Originally by: Attiladehun
Edited by: Attiladehun on 02/09/2009 11:17:25
Hey Sakari,

Can you check out the T3 cruisers?
I tried a setup of the loki with "Adaptive Augmenter" which gives a bonus of 5% resist per lvl on armor.
When i set my skills to lvl5 or lvl0 nothing changes on the resists. Only on hardeners the situation changes.
Log:
mainWindow.py:443: GtkWarning: Don't know color `<GdkColor at 0x1866f50>'
Traceback (most recent call last):
File "gui\mainWindow.pyo", line 1531, in itemsClicked
File "gui\mainWindow.pyo", line 1221, in addItem
File "gui\mainWindow.pyo", line 549, in fittingChanged
File "model\fitting.pyo", line 574, in calculateModifiedAttributes
TypeError: unsupported operand type(s) for +: 'exceptions.KeyError' and 'str'
library.zip\gui\mainWindow.py:443: GtkWarning: Don't know color `<GdkColor at 0x1873000>'
library.zip\gui\mainWindow.py:443: GtkWarning: Don't know color `<GdkColor at 0x186f090>'
library.zip\gui\mainWindow.py:443: GtkWarning: Don't know color `<GdkColor at 0x186f000>'
This flaw seems to be fixed in latest git version

Sakari Orisi
BIG
Gentlemen's Agreement
Posted - 2009.09.02 16:10:00 - [167]
 

Originally by: Kadesh Priestess
Originally by: Attiladehun
Edited by: Attiladehun on 02/09/2009 11:17:25
Hey Sakari,

Can you check out the T3 cruisers?
I tried a setup of the loki with "Adaptive Augmenter" which gives a bonus of 5% resist per lvl on armor.
When i set my skills to lvl5 or lvl0 nothing changes on the resists. Only on hardeners the situation changes.
Log:
mainWindow.py:443: GtkWarning: Don't know color `<GdkColor at 0x1866f50>'
Traceback (most recent call last):
File "gui\mainWindow.pyo", line 1531, in itemsClicked
File "gui\mainWindow.pyo", line 1221, in addItem
File "gui\mainWindow.pyo", line 549, in fittingChanged
File "model\fitting.pyo", line 574, in calculateModifiedAttributes
TypeError: unsupported operand type(s) for +: 'exceptions.KeyError' and 'str'
library.zip\gui\mainWindow.py:443: GtkWarning: Don't know color `<GdkColor at 0x1873000>'
library.zip\gui\mainWindow.py:443: GtkWarning: Don't know color `<GdkColor at 0x186f090>'
library.zip\gui\mainWindow.py:443: GtkWarning: Don't know color `<GdkColor at 0x186f000>'
This flaw seems to be fixed in latest git version

Indeed, you can expect a release with the fix (among other things) within a few days.

Toksyuryel
Gallente
Domestic Tentacle Supply
Posted - 2009.09.02 19:35:00 - [168]
 

I've been having a hell of a time getting this to run in Gentoo. I upgraded to Python 2.6 and went through the python-updater process (which included updates for pygtk and all its deps) and I am still not able to run this. The error I am receiving follows:
$ python launch.py 
Traceback (most recent call last):
File "launch.py", line 18, in <module>
import gtk
ImportError: No module named gtk
I also checked with eselect and 2.6 was already active according to it, so I'm really at a loss for what could be going on here. Any help would be greatly appreciated.

Drake Draconis
Minmatar
Shadow Cadre
Shadow Confederation
Posted - 2009.09.02 20:43:00 - [169]
 

Originally by: Toksyuryel
I've been having a hell of a time getting this to run in Gentoo. I upgraded to Python 2.6 and went through the python-updater process (which included updates for pygtk and all its deps) and I am still not able to run this. The error I am receiving follows:
$ python launch.py 
Traceback (most recent call last):
File "launch.py", line 18, in <module>
import gtk
ImportError: No module named gtk
I also checked with eselect and 2.6 was already active according to it, so I'm really at a loss for what could be going on here. Any help would be greatly appreciated.


Stupid Question - Did you check to see that GTK Itself was installed with all deps?
This was a problem I encountered on the Macs when I started messing with PYFA.

Toksyuryel
Gallente
Domestic Tentacle Supply
Posted - 2009.09.02 21:05:00 - [170]
 

Edited by: Toksyuryel on 03/09/2009 00:33:28
Yeah, gtk is installed :P though I suppose I could reinstall it. Maybe that would trick it into working.

EDIT: Yeah that didn't work :(

Biakuzolm
Posted - 2009.09.03 08:45:00 - [171]
 

Edited by: Biakuzolm on 03/09/2009 08:51:23
Thanks for this great app!

I've had little issues using it but I don't know whether it's because I don't now how to use all features or because they are not implemented yet.

1. Beside the tooltip for every module, I did not find how to get their detailed attributes.
2. I did not find how to export a loadout, either in XML format or in the clipboard.
3. I did not find how to load ammo in weapons to compute the DPS.
4. When searching for example a "Ballistic Control System I" module by typing "Ballistic" in the search field, I get several "Ballistic []" or "[] Ballistic" modules, but not the one I was searching. I have to add a few information more to the search field to get it, per instance "Ballistic c". It's obviously not a big deal, but I'm wondering why this module is not displayed after the first request. There are probably other examples.

Sorry if these are dumb questions/reports.

Originally by: Ancy Denaries
Originally by: Lan Staz
Oh no - VirtualBox and WinXP are getting close to vanishing from my PCs !

Very Happy

Keep up the good work Sakari.
Haha! I felt the same way! Now if I could only get Evemon running, or gtkEVEmon gets up to spec...
Actually, EVEMon is running almost flawlessly through Wine 1.1.28 for me. I installed GtkEVEMon, but it really lacks a ship browser in my opinion (as well as the possibility to plan all the skills needed by the ships browsed). I'll use it when these features will be added. EFT runs well through Wine too, I can't display Informations windows for the modules already fitted nor compute the DPS, but everything except that worked so far. At the moment, I'm using EVEMon and Pyfa.

Kadesh Priestess
Scalding Chill
Posted - 2009.09.03 10:24:00 - [172]
 

Originally by: Biakuzolm
1. Beside the tooltip for every module, I did not find how to get their detailed attributes.
Known drawback, there're few ideas how to show such info but Sakari is currently busy with implementing plugin framework.
Originally by: Biakuzolm
2. I did not find how to export a loadout, either in XML format or in the clipboard.
There's an export button right to setup selection button.
Originally by: Biakuzolm
3. I did not find how to load ammo in weapons to compute the DPS.
Find ammo in item browser, select desired module in your setup and RMB on ammo => load, or load all (latter loads in all modules suitable for selected ammo type). Yea, not very convenient too, but as far as i understand this is also subject for changes.
Originally by: Biakuzolm
4. When searching for example a "Ballistic Control System I" module by typing "Ballistic" in the search field, I get several "Ballistic []" or "[] Ballistic" modules, but not the one I was searching. I have to add a few information more to the search field to get it, per instance "Ballistic c". It's obviously not a big deal, but I'm wondering why this module is not displayed after the first request. There are probably other examples.
Try scrolling down a bit, filtering is correct for me, though there's still no sorting.

Biakuzolm
Posted - 2009.09.03 11:19:00 - [173]
 

Originally by: Kadesh Priestess
Originally by: Biakuzolm
1. Beside the tooltip for every module, I did not find how to get their detailed attributes.
Known drawback, there're few ideas how to show such info but Sakari is currently busy with implementing plugin framework.
Originally by: Biakuzolm
2. I did not find how to export a loadout, either in XML format or in the clipboard.
There's an export button right to setup selection button.
Originally by: Biakuzolm
3. I did not find how to load ammo in weapons to compute the DPS.
Find ammo in item browser, select desired module in your setup and RMB on ammo => load, or load all (latter loads in all modules suitable for selected ammo type). Yea, not very convenient too, but as far as i understand this is also subject for changes.
Originally by: Biakuzolm
4. When searching for example a "Ballistic Control System I" module by typing "Ballistic" in the search field, I get several "Ballistic []" or "[] Ballistic" modules, but not the one I was searching. I have to add a few information more to the search field to get it, per instance "Ballistic c". It's obviously not a big deal, but I'm wondering why this module is not displayed after the first request. There are probably other examples.
Try scrolling down a bit, filtering is correct for me, though there's still no sorting.
Shame on me. I was not using the last Pyfa version. Downloaded the new one and I actually see the export button, which was not present, and search works just right too (it didn't on the version I tested, I scrolled). Thanks for your answer!

Sakari Orisi
BIG
Gentlemen's Agreement
Posted - 2009.09.03 15:14:00 - [174]
 

Details of any item/drone/skill/gang bonus/whatever can be seen simply be right clicking the thing in question and clicking "View Stats"

DZ Cielo
Argon .Inc
STR8NGE BREW
Posted - 2009.09.03 16:56:00 - [175]
 

Edited by: DZ Cielo on 03/09/2009 16:58:21
ok seem to have found a problem. with the set up below pyfa tells me my passive shield recharge is 71.0 hps with my current skills. eft says its 51.94 and the ingame fitting screen says its 40hps.

if i understand correctly the ingame one will change as i take a beatting cos my shield regen goes up as they take more damage but theres still a big difference between eft and pyfas numbers :S updated my api on both so my skills are upto date. so which is right and which is wrong.

[Caracal, Caracal]

'Arbalest' Standard Missile Launcher, Bloodclaw Light Missile
'Arbalest' Standard Missile Launcher, Bloodclaw Light Missile
'Arbalest' Standard Missile Launcher, Bloodclaw Light Missile
'Arbalest' Standard Missile Launcher, Bloodclaw Light Missile
'Arbalest' Standard Missile Launcher, Bloodclaw Light Missile

Large F-S9 Regolith Shield Induction
Large F-S9 Regolith Shield Induction
Heat Dissipation Amplifier I
Kinetic Deflection Amplifier I
Magnetic Scattering Amplifier I

Beta Reactor Control: Shield Power Relay I
Ballistic Control System I

Medium Core Defence Field Purger I
Medium Core Defence Field Purger I
Medium Core Defence Field Purger I


Hornet I x2

DZ Cielo
Argon .Inc
STR8NGE BREW
Posted - 2009.09.03 17:16:00 - [176]
 

problem seems to be the resistance amplifiers, when i take those off my fit the numbers match in eft and pyfa. only when i add the resistance amps in pyfa do they change, in pyfa my shield recharge rate goes up when i add amps, in eft it doesnt,

hope this helps

Sakari Orisi
BIG
Gentlemen's Agreement
Posted - 2009.09.03 17:33:00 - [177]
 

Edited by: Sakari Orisi on 03/09/2009 17:47:24
Originally by: DZ Cielo
problem seems to be the resistance amplifiers, when i take those off my fit the numbers match in eft and pyfa. only when i add the resistance amps in pyfa do they change, in pyfa my shield recharge rate goes up when i add amps, in eft it doesnt,

hope this helps

That makes no sense, the amps should increase your passive tank.

edit: after fixing a bug with large shield extenders not getting bonusses from skills in pyfa I'm getting 107.9 HP/S in pyfa and 108HP/S in EFT (most likely rounded). thanks for the bug report !

Kadesh Priestess
Scalding Chill
Posted - 2009.09.03 17:48:00 - [178]
 

LSE bugged out. Shield management didn't affect it, should be fixed in next build.

DZ Cielo
Argon .Inc
STR8NGE BREW
Posted - 2009.09.03 18:06:00 - [179]
 

The LSE's seem fine for me, ubless you mean its a bug in eve itself which is probably why it only gives me 40.0 in the in game fitting screen but both eft and pyfa give me 51.94hps without any amps, soon as i add "Heat Dissipation Amplifier I", "Kinetic Deflection Amplifier I" and "Magnetic Scattering Amplifier I" it changes in eft it stays at 51.94hps but in pyfa it goes upto 71.0.

so i'm guessing the bug with the LSEs is in eve itself?

Sakari Orisi
BIG
Gentlemen's Agreement
Posted - 2009.09.03 18:12:00 - [180]
 

Originally by: DZ Cielo
The LSE's seem fine for me, ubless you mean its a bug in eve itself which is probably why it only gives me 40.0 in the in game fitting screen but both eft and pyfa give me 51.94hps without any amps, soon as i add "Heat Dissipation Amplifier I", "Kinetic Deflection Amplifier I" and "Magnetic Scattering Amplifier I" it changes in eft it stays at 51.94hps but in pyfa it goes upto 71.0.

so i'm guessing the bug with the LSEs is in eve itself?


The bug with LSEs was in pyfa, it didn't add bonusses from skills to shield capacity to extenders


Pages: first : previous : ... 2 3 4 5 [6] 7 8 9 10 ... : last (13)

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only