open All Channels
seplocked Market Discussions
blankseplocked jEveAssets
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: first : previous : ... 9 10 11 12 [13] 14 15 16 17 ... : last (20)

Author Topic

Golden Gnu
Gallente
The Golden Gnu Corp
Posted - 2010.05.17 10:06:00 - [361]
 

@Vaerah Vahrokha
Okay, I've added both to the issue list... they'll properly be in the next feature release... :)

SencneS
Rebellion Against Big Irreversible Dinks
Posted - 2010.05.17 15:09:00 - [362]
 

Here is a nice little request that I and a few others have been doing recently might be good to add.

A screen that shows "Volume" by System... (Make it sortable)
Like let say you have junk everywhere and in systems you have multiple hangers at multiple stations. The station may only have 30-40K m3 but there is 12 stations in that system.

So sorting by system over all value, cargo size across the entire system would be VERY useful.

We're doing it at the moment but we're using Excel and exports, then formulas to calculate cargo and value. Call it "System Report" or something.

Golden Gnu
Gallente
The Golden Gnu Corp
Posted - 2010.05.17 15:25:00 - [363]
 

@SencneS
Take a look at issue 95, I think that is what you want? It's a planed feature for 1.5.0...

Also, If you just enter the system name, as a filter, you should get: volume, items count, avg value, total value, in the statusbar...

SencneS
Rebellion Against Big Irreversible Dinks
Posted - 2010.05.17 15:34:00 - [364]
 

Originally by: Golden Gnu
@SencneS
Take a look at issue 95, I think that is what you want? It's a planed feature for 1.5.0...

Also, If you just enter the system name, as a filter, you should get: volume, items count, avg value, total value, in the statusbar...

Yeah actually that is pretty much the exact what I am talking about. A list of systems that sort by value and cargo size :)

And yeah it does give a overview, but we're talking across an entire region at least 30 systems. It's easier to just use the excel sheet and formula the m3 and value then it is to filter system by system.

Golden Gnu
Gallente
The Golden Gnu Corp
Posted - 2010.05.17 16:57:00 - [365]
 

@SencneS
Noted: Sorting is important... ;)

Golden Gnu
Gallente
The Golden Gnu Corp
Posted - 2010.05.19 09:38:00 - [366]
 

jEveAssets 1.4.1 (Dominion 1.1.1) released

Bug fixes:
-Routing: Brute Force don't return shortest route (Issue 85)
-Conquerable stations are never saved (Issue 98)

Notes:
-It's not possible the revert back to version 1.3.0 (or earlier) and keep your settings after running 1.4.1
-Mac users upgrading (from 1.3.0 or earlier) need to move their settings manually:
Move the .jEveAssets directory from ~user/ it to ~user/Library/Preferences/
Rename .jEveAssets to JEveAssets

Richard Christy
Posted - 2010.05.20 12:25:00 - [367]
 

Edited by: Richard Christy on 20/05/2010 12:29:47
A great tool, and it was nice to finally find some stuff that has been AWOL for some time.

Anyway, I extracted it to a folder, ran the executable jar file, entered all my APIs, and updated.

However, there was no executable file that I could run to start the program, so when I close it, I seem to lose all my APIs, because I have to re-run the jar file to get the program to start. I am using win XP.

Am I missing something here?

Thanks for a good tool, I hope I can get it to work, it'll suck to have to enter all my APIs every time, or leave the program open 24/7


Got it working now. -.-

Golden Gnu
Gallente
The Golden Gnu Corp
Posted - 2010.05.20 14:40:00 - [368]
 

Edited by: Golden Gnu on 20/05/2010 14:40:36

@Richard Christy
I'm happy you got it working... :)
May I ask what you did to fix the problem? - and if you know, what you did wrong, since it didn't save the API keys etc.?

SencneS
Rebellion Against Big Irreversible Dinks
Posted - 2010.05.20 16:12:00 - [369]
 

Originally by: Golden Gnu
@SencneS
Noted: Sorting is important... ;)


Been thinking about it for a few days and my request actually has "changed" a little from what Issue 95 is all about. I'll create a new one.. It created an Issue not an Enhancement so please forgive that or change it please :)

Richard Christy
Posted - 2010.05.20 16:24:00 - [370]
 

Edited by: Richard Christy on 20/05/2010 16:27:45
Originally by: Golden Gnu
Edited by: Golden Gnu on 20/05/2010 14:40:36

@Richard Christy
I'm happy you got it working... :)
May I ask what you did to fix the problem? - and if you know, what you did wrong, since it didn't save the API keys etc.?


iirc, I was playing with the various entries in the "tools" menu. When I hit "routing", it crashed. The next time I ran the jar file, nothing showed up in the program. So I exited it, posted my question, and re-ran it.

Then I re-entered all the API data, and it's fine now.

Edit - added the bit about "routing".

Golden Gnu
Gallente
The Golden Gnu Corp
Posted - 2010.05.20 18:11:00 - [371]
 

@SencneS
I read you feature request: I think it's a good idea, but, I don't know if it'll be in the first release of the tool, as it's a lot of work...

@Richard Christy
What version are you using? 1.4.1 was released just to fix that bug...

Richard Christy
Posted - 2010.05.21 12:10:00 - [372]
 

Originally by: Golden Gnu
@Richard Christy
What version are you using? 1.4.1 was released just to fix that bug...


I am using 1.4.1.

Flaming Candle
Posted - 2010.05.21 12:21:00 - [373]
 

Originally by: Richard Christy
Edited by: Richard Christy on 20/05/2010 16:27:45
Originally by: Golden Gnu
Edited by: Golden Gnu on 20/05/2010 14:40:36

@Richard Christy
I'm happy you got it working... :)
May I ask what you did to fix the problem? - and if you know, what you did wrong, since it didn't save the API keys etc.?


iirc, I was playing with the various entries in the "tools" menu. When I hit "routing", it crashed. The next time I ran the jar file, nothing showed up in the program. So I exited it, posted my question, and re-ran it.

Then I re-entered all the API data, and it's fine now.

Edit - added the bit about "routing".
The issue with 1.4.0 was that it wasn't saving the conquerable station data properly. When you started up 1.4.1 the second time, it probably re-downloaded the conquerable station data and then saved it in the correct way.

Vaerah Vahrokha
Minmatar
Vahrokh Consulting
Posted - 2010.05.22 12:47:00 - [374]
 

Edited by: Vaerah Vahrokha on 22/05/2010 13:13:38
v 1.4.1

1) Menu Options|Profiles... has a typo: "Profiels...".

2) Applied filters persist thru profiles changes. It'd be nice to have an option to remove them or have a pop up warning about that, since it's easy to miss it and get reduced information on the next aditees.

3) When updating, in case of issues, the relevant window grows to huge length.
I'd suggest to put the window inside a scroll box (no idea how it's called in Java, the control that beyond a preset size will show scroll bars instead of having the containing window expand.

Please visit your user settings to re-enable images.

This also evidenced another tip: the button to close the update window should be focused by default so that it's possible to close it just by pressing ENTER.
Otherwise there's no way to dismiss the window except minimizing all the warning entries by hand. In fact, the popup expands to below the desktop bottom and buttons disappear as per the above picture.

Finally, imho the thing could be minimized by having the popup center itself after clicking on a "warning sign icon".

Golden Gnu
Gallente
The Golden Gnu Corp
Posted - 2010.05.23 08:44:00 - [375]
 

Edited by: Golden Gnu on 26/05/2010 12:11:07

@Vaerah Vahrokha
1) Already reported and will be fixed :)

2) I Agree, filters should be cleared when loading a new profile. Thank you for pointing that out.

3) Yes, scroll bars ftw.

Thank you for your continued feedback. It's some very good suggestions you come up with. :)

EDIT
3) I've redesigned the dialog. It's now movable and only show errors for one task at a time. I think the design is better now, if you find anything (when it's release) that would improve it further, please let me know...

Golden Gnu
Gallente
The Golden Gnu Corp
Posted - 2010.05.30 10:18:00 - [376]
 

jEveAssets 1.4.1 (Tyrannis 1.0.0) released

Changes:
-Tyrannis 1.0.0 data files

Notes:
-It's not possible the revert back to version 1.3.0 (or earlier) and keep your settings after running 1.4.1
-Mac users upgrading (from 1.3.0 or earlier) need to move their settings manually:
Move the .jEveAssets directory from ~user/ it to ~user/Library/Preferences/
Rename .jEveAssets to JEveAssets

Golden Gnu
Gallente
The Golden Gnu Corp
Posted - 2010.06.04 10:55:00 - [377]
 

jEveAssets 1.4.1 (Tyrannis 1.0.1) released

Changes:
-Tyrannis 1.0.1 data files

Notes:
-It's not possible the revert back to version 1.3.0 (or earlier) and keep your settings after running 1.4.1
-Mac users upgrading (from 1.3.0 or earlier) need to move their settings manually:
Move the .jEveAssets directory from ~user/ it to ~user/Library/Preferences/
Rename .jEveAssets to JEveAssets

Snabbik Shigen
Posted - 2010.06.11 01:56:00 - [378]
 

Is it going to be possible for jEVEAssets to keep track of resources stored in planet-side storage or sitting in the Customs Office?

Golden Gnu
Gallente
The Golden Gnu Corp
Posted - 2010.06.11 10:00:00 - [379]
 

Edited by: Golden Gnu on 12/06/2010 14:23:00
@Snabbik Shigen
TBH, I don't know... I'll have to do some research first...

EDIT:
Planet side stuff is not accessible from the API...
I still have to test if stuff in the costume office show up in the asset list (give me 4 days or so, to train some skills)

Tonto Auri
Vhero' Multipurpose Corp
Posted - 2010.06.12 21:46:00 - [380]
 

How to force an assets update?
I understand that normally CCP don't allow fetching them earlier than 24h after last update, but I happen to have 2 separate external IP's... (And can get hold on two more, if need)

Golden Gnu
Gallente
The Golden Gnu Corp
Posted - 2010.06.13 08:49:00 - [381]
 

@Tonto Auri
AFAIK, you can update assets as much as you like, but, you'll just get a cached result...

However, if you wish to hammer the API, you can....
-Goto: Menu > Options > Options... > Proxy
-Check "Enable API Proxy"
-Enter "http://api.eve-online.com" in the field bellow...
-Press OK

Warning: Use this at your own risk! It's not the way jEveAssets, is meant to be used...

Tonto Auri
Vhero' Multipurpose Corp
Posted - 2010.06.13 13:39:00 - [382]
 

Edited by: Tonto Auri on 13/06/2010 13:51:46
Originally by: Golden Gnu
@Tonto Auri
AFAIK, you can update assets as much as you like, but, you'll just get a cached result...

However, if you wish to hammer the API, you can....
-Goto: Menu > Options > Options... > Proxy
-Check "Enable API Proxy"
-Enter "http://api.eve-online.com" in the field bellow...
-Press OK

Warning: Use this at your own risk! It's not the way jEveAssets, is meant to be used...


Erm. That could work. BRB...

(To clarify, the API requests limited on a feed-per-key-per-IP basis. I.e., if you have two keys with identical corp rights, you can update corporation assets twice a day. If you have two different IP's [your IP changes from connection to connection], you can update sooner using the same key)
I have two internet connections here and can get a proxy access to two more hosts. And I have two characters with identical corp access rights.
I can, potentically, refresh the corp assets every 4 hours. I know, my case isn't common, but at least for scenario "two accounts in a corp with the same rights" it is something to consider as an improvement to your application. IMHO Wink

Golden Gnu
Gallente
The Golden Gnu Corp
Posted - 2010.06.13 16:00:00 - [383]
 

@Tonto Auri
Please, remember that the cache time is there for a reason...

Tonto Auri
Vhero' Multipurpose Corp
Posted - 2010.06.13 16:05:00 - [384]
 

Originally by: Golden Gnu
@Tonto Auri
Please, remember that the cache time is there for a reason...


I know and not intend to abuse this possibility.
But 24 hours delay between assets listing is just too much for me.

DethApostle
Amarr
Ammo and Tag
Ninja Unicorns with Huge Horns
Posted - 2010.06.13 18:51:00 - [385]
 

Not a major issue but...
Profiles under the 'Options' tab is spelt wrong. (assuming English was the intended language of course!)

gigitrix
Posted - 2010.06.13 23:42:00 - [386]
 

Just another happy user here (but I second, third and fourth the Stations->Volume view idea mentioned a while back (I'd offer ISK for implementation but I'm poor Very Happy)

Keep on truckin' with this excellent app :)

Vaerah Vahrokha
Minmatar
Vahrokh Consulting
Posted - 2010.06.14 07:13:00 - [387]
 

Quote:

(To clarify, the API requests limited on a feed-per-key-per-IP basis. I.e., if you have two keys with identical corp rights, you can update corporation assets twice a day. If you have two different IP's [your IP changes from connection to connection], you can update sooner using the same key)



There is a way to refresh the 1 day CD API every few hours, sometimes every 2 hours.

BUT I chose not to (ab)use of it.


Quote:

But 24 hours delay between assets listing is just too much for me.



See, your idea of deserving a special treatment and have shorter refresh time is understandable but it's dishonest.

Taken to the extreme, CCP might nerf API querying and force a 24h cooldown regardless of IP used and then we'll have to thank those who felt like not to wait for the intended timeout.
Why isn't it possible for people to self-regulate responsibly and see the long term consequences? Peregrine question, isn't it?



Quote:

Not a major issue but...
Profiles under the 'Options' tab is spelt wrong. (assuming English was the intended language of course!)



Signalled in my previous post already.

It's prolly slipped thru. It's not the kind of bug that leaves programmers sleepless in the night.
(The kind that makes me sleepless is when my multithread C++ or Delphi program crashes for no reason after hours, with no way to replicate why). Can't accept software that crashes here.


Quote:

Just another happy user here (but I second, third and fourth the Stations->Volume view idea mentioned a while back (I'd offer ISK for implementation but I'm poor )



Another happy user here.

I suggest happy users to thank the Developers of this wonderful app with ISK.
I am going to send another 100M when I see PI put in this app, the proper way (there are some PI apps but are rought to say the least).
IE I'd love to plan some split factory / manufacture setups and deploy them in 0.0, knowing they'll actually work.

Golden Gnu
Gallente
The Golden Gnu Corp
Posted - 2010.06.14 09:44:00 - [388]
 

Edited by: Golden Gnu on 15/06/2010 13:24:22
@Tonto Auri
Yes, 24 hours is a long time. I would love it if the cache time was lower. However, don't abuse the API, as it's the life nerve of jEveAssets.


@DethApostle
Already reported and fixed (in SVN trunk). The part in parentheses made me laugh. I hope the general impression, is that the program is in English... Wink


@gigitrix
I'm glad you like the program. Happy user are the best thing in the world, really...

If you refer to the overview feature, It's already completed, I just need to do the rest of the planed features, before we release a new version... :)


@Vaerah Vahrokha
Thank you for your great reply YARRRR!!

I'm just going to comment on the PI part Wink
I'm not sure a PI planer should be part of jEveAssets. I don't want jEveAssets to end up doing everything. I want to narrow the scope to assets.

While assets on planets, should definitely be part of jEveAssets, I think that a PI planer/builder (as well as a POS planer) is out of the scope. There is still no API for getting assets on planets, so, that will have to wait...

Also, the apps that do PI planing, will properly mature and be awesome in the future...
It took quite some time before jEveAssets matured and ironed out the most fatal bugs...

Edited spelling

Gladys Pank
Amarr
Trillionaire High-Rollers Suicidal Bassoon Orkesta
Posted - 2010.06.17 13:58:00 - [389]
 

Hi there and thanks for a great app.

I have an error, havent been able to see any mention of it so far, don't know if you are aware of it...

I updated from version 1.2 something up to 1.41 and now on initialising jeveassets I get an error message, after which jeveassets closes.

My Java is up to date, running on XP pro with all the latest updates. I'm not hugely tech savvy so not sure if I am missing something obvious.

Golden Gnu
Gallente
The Golden Gnu Corp
Posted - 2010.06.17 14:43:00 - [390]
 

Edited by: Golden Gnu on 17/06/2010 15:03:25
@Gladys Pank
I have no idea how that could happen - but, you can work around it, by manually moving the file.

1) Go to the "C:\Documents and Settings\[USERNAME]\.jeveassets\data\"
2) Move the "assets.xml" file to C:\Documents and Settings\[USERNAME]\.jeveassets\profiles\
(if the the "profiles" folder doesn't exist create it)

Replace [USERNAME] with your username

I hope this will solve your problem. If not, just post here again...

Edit
You should move (cut and paste) the file (not copy) Rolling Eyes


Pages: first : previous : ... 9 10 11 12 [13] 14 15 16 17 ... : last (20)

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only