open All Channels
seplocked Macintosh
blankseplocked Mac Eve Tools: Mac based Skill planner & Character Sheet
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: first : previous : ... 7 8 9 10 [11] 12 13 14 15 ... : last (19)

Author Topic

Rottenator
The Littlest Hobos
En Garde
Posted - 2010.01.27 10:45:00 - [301]
 

Originally by: Cyllena
Yeah, Mac EVE Tools have not downloaded my charater portrait.

There wasn't a portrait for you on the forums until I just refreshed. The portrait is not generated and put into the api immediately after character creation. This takes some time. I think, as your portrait is now on the forums too, it might now also be in the api. Try the same you did later today and you'll probably see it properly.

Originally by: Cyllena
Sybmol = Appicon in the dock... :)

Yeah the application icon is still not there. I really would like a neat one. Maybe if some people send him a really cool one he adds it Razz

Cyllena
Amarr
Imperial Shipment
Posted - 2010.01.27 14:04:00 - [302]
 

Ah, whats with multilanguage?
Are the Skill, Cert and Shipdescriptions availible in other languages over API or your way?
If you like, i can help you to translate the app into german.

Cadfan
Posted - 2010.01.27 17:24:00 - [303]
 

Flammard,

Just wanted to thank you for such a great tool!!! The only thing it was missing was the Certificate planner and you plugged that hole. I use it almost daily, your hard work is truly appreciated! Thank you again.

Flammard
Caldari
The New Era
C0NVICTED
Posted - 2010.01.28 02:43:00 - [304]
 

Edited by: Flammard on 28/01/2010 02:50:16
Originally by: Rottenator
Yeah the application icon is still not there. I really would like a neat one. Maybe if some people send him a really cool one he adds it Razz

Pretty much this :) I don't really have any interest or talent in the area of graphic design. If someone can make an icon i'll add it and give you credit. Until then the crappy default icon remains :)

Originally by: Cyllena
Ah, whats with multilanguage?
Are the Skill, Cert and Shipdescriptions availible in other languages over API or your way?
If you like, i can help you to translate the app into german.

As far as I know, the skill, ship and certificate information obtained through the API (eg: http://api.eve-online.com/eve/SkillTree.xml.aspx ) is only available in English (someone let me know if this isn't the case). You're welcome to translate the rest of the program if you like, though most of the information will be in English due to the XML files. See the first post for my email address and send me an email.

Has your picture shown up yet? as Rottenator said it takes a few days for new characters as the server needs to generate it.

Originally by: Cyllena
But for Quit and Hide there is the wrong app name: MacEveApi :) Should be changed to new name :-P

Oops. I'll fix that in the next release.

Cyllena
Amarr
Imperial Shipment
Posted - 2010.01.28 11:03:00 - [305]
 

My portrait dont changed, it is the ! on black background.
Dont see my portrait...

Maar'sha
Les chevaliers de l'ordre
Posted - 2010.01.28 17:55:00 - [306]
 

Hi,

I use your software since his beginnings and I like it.

It is the software which the players of EVE missed it on mac.

The remaining time of a partially trained skill is updated only in the list of all skill when I stop it but when I restart it the skillqueue is not updated with the remaining time.

English is not my favorite language and I have difficulties for explain the bug Sad

Iino Katou
Posted - 2010.01.29 12:08:00 - [307]
 

Edited by: Iino Katou on 29/01/2010 13:27:01
Edited by: Iino Katou on 29/01/2010 12:09:07
Edited by: Iino Katou on 29/01/2010 12:08:44
Originally by: Flammard
Pretty much this :) I don't really have any interest or talent in the area of graphic design. If someone can make an icon i'll add it and give you credit. Until then the crappy default icon remains :)


Download this archive:
http://downloads.eve-online.com/data/Dominion_1.0.3_imgs.7z

Look for icons/64_64/icon02_16.png and use it as the app icon for the time being, until you decide on a name for the app. If you decide on renaming the app some different icon might be more appropriate.

edit: might need different icon sizes, up to 512x512... back to the drawing board! :)

PS: Thanks for all the effort you put into this, the app is a lifesaver for us Mac users.

Cyllena
Amarr
Imperial Shipment
Posted - 2010.01.29 15:21:00 - [308]
 

There are many icons, the 02_16 ists my favorite one :) Flammard should choose one :)

Flammard
Caldari
The New Era
C0NVICTED
Posted - 2010.02.01 23:17:00 - [309]
 

Originally by: Maar'sha
The remaining time of a partially trained skill is updated only in the list of all skill when I stop it but when I restart it the skillqueue is not updated with the remaining time.

English is not my favorite language and I have difficulties for explain the bug Sad


I'm not really sure what you mean.

On the character sheet, there are number of spots that are only updated when the page is drawn. the 24hr skill queue is one of them. The countdown isn't a live update. Only the 'Remaining:' section is a live update.

Maar'sha
Les chevaliers de l'ordre
Posted - 2010.02.04 11:43:00 - [310]
 

Originally by: Flammard
I'm not really sure what you mean.

On the character sheet, there are number of spots that are only updated when the page is drawn. the 24hr skill queue is one of them. The countdown isn't a live update. Only the 'Remaining:' section is a live update.

It's exactly the answer I want Razz

Cyllena
Amarr
Imperial Shipment
Posted - 2010.02.06 10:38:00 - [311]
 

Edited by: Cyllena on 06/02/2010 10:41:10
Found some more bugs and hints:

1. My portrait didnt work. But this is buggy in forums too.
2. I like to have the 100% bonus included (okay, im out sone, but its important for new ppl :-P)
3. I like to add a skill from the character sheet to a skillplan. Can be like -> Right klick -> Add to -> "Skillplan" (this is not important)
4. Change color of skills that are in a skillplan in Character sheed and show the highest planed level
5. If a skill is already in another plan, a warning can be nice, when i try to add it one more plan

But dont hury. In germany we say: Immer langsam mit den jungen Pferden.

Translation: Always be slow with the young horses.


Maar'sha
Les chevaliers de l'ordre
Posted - 2010.02.06 20:21:00 - [312]
 

Hi,

Is it a bug or not ?

I train Bomb Deployement I wich requires Missile bombardement IV (check in EVE).

The software indicates to me that I must have Missile bombardment V before learning Bomb deployement what is false.

Sarahphim KTS
Caldari
3D Salvage and Acquisitions
Posted - 2010.02.09 13:10:00 - [313]
 

I downloaded this about a week ago and I've been using it since. Pretty good software. I just wanted to say thank you. :)

SarahPhim KTS

Swearte Widfarend
Gallente
Aurora Security
Posted - 2010.02.09 18:15:00 - [314]
 

Originally by: Maar'sha
Hi,

Is it a bug or not ?

I train Bomb Deployement I wich requires Missile bombardement IV (check in EVE).

The software indicates to me that I must have Missile bombardment V before learning Bomb deployement what is false.


The data dump must be from Apocrypha then. Prior to Dominion you needed MB V for Bomb Deployment

Flammard
Caldari
The New Era
C0NVICTED
Posted - 2010.02.10 00:14:00 - [315]
 

Currently the skill data comes from the XML API and is not automatically updated. I'm in the process of converting everything over to use the database export. It should be easier to manage versions and you can also use the German and Russian language translations in the database.

In the mean time you can force an update by doing this

Open finder, go to your home directory
Navigate to Library / Application Support / MacEveApi
And then Delete SkillTree.xml.aspx
Restart the program and it will download the new skill tree for dominion.

Alt Nearing
Posted - 2010.02.12 13:11:00 - [316]
 

Now that i have this Ship-Database, where is the button to view those ship details? I installed the database + restarted but there is no option to browse ships?

Darkmorphix
Posted - 2010.02.12 18:53:00 - [317]
 

This is an amazing tool! I'd like to express my appreciation to Flammard for his hard work and generous nature. Thank you for sharing this great application with Mac EVE pilots. Cheers!

Disco Jack
Posted - 2010.02.13 03:57:00 - [318]
 

Edited by: Disco Jack on 13/02/2010 14:03:58
Edited by: Disco Jack on 13/02/2010 14:02:49
http://img43.imageshack.us/img43/7697/screenshot20100212at114.jpg

This is a screenshot of your app with a few circles references.

Notice my avatar isn't loading either, not sure what it is but I've noticed on two characters that the pic doesn't want to load. You can see from my SP too that I'm not any newer than 3 weeks.

Come to think of it.. the 2/3 pictures that don't load are from characters that I NEVER log onto from my primary client, I duel-box sometimes so I have one client for one account, and one for the other.. <fiddles>. meh, I tried to log onto that character thinking maybe the portrait was being pulled from my primary clients cache but no cigar.

Sometimes when there is only one long (more than 24h) skill in the queue, and it's partially trained, the two red circles (refer to image linked above) show the time it would take to train the skill from the beginning of that level. The blue circle value does however display the true value for remaining time.

Sometimes it's confusing when waiting for my queue to drop below 24hrs when I go to check because I'm sure that I should be able to update the queue, but the queue window and the two red values are misleading, only when I do a double-take and check the blue value am I sure that my queue is ready to update.

I think I've seen the same issue on capsuleer for iPod.

The app works awesome though :) and to whoever asked about wanting to see the ship info from the planner view, just double click on the ship, or right click and click on the ship name in the pop-up menu.

Very good job with the app, love the new improvements. Got myself a training queue with 98 days left on it before I remap lol... trying to bridge the gap between me and a lot of experienced players.

EDIT: Ok I get it, why the reds and blue don't show the same time sometimes, I think someone explained it earlier but I glazed over it and only now understood when I saw it.

The two values in RED only update when you manually refresh your characters information, and do not countdown like the BLUE value. So if a person isn't reloading their API information, or the API server isn't updating at that time, a person is shown a full queue.. totally get it now haha.

Not sure why the pics aren't loading yet all the same.

One more thing I've noticed with the training plan. If you partially trained a skill, and then removed it from your queue until a more convenient time to finish, the training plan does not reflect the correct progress. The "Training Time" column shows the time remaining for that level of the skill, and the progress shows 0%.

Example, I have salvaging IV about half-trained. 1d 21 hr 9m would be the total time, I have 21h 42m remaining that I will train eventually, the training planners shows the training time to be 21h 42m, and like I said earlier, the progress shows 0%, the info-of-the-skill still shows the correct total, and remaining, training times. So perhaps the the reference in the "training time" column needs to be adjusted.

I think the progress % formula may sort itself out after that but it would be the next thing to check.

Rottenator
The Littlest Hobos
En Garde
Posted - 2010.02.13 14:29:00 - [319]
 

Originally by: Disco Jack

The two values in RED only update when you manually refresh your characters information, and do not countdown like the BLUE value. So if a person isn't reloading their API information, or the API server isn't updating at that time, a person is shown a full queue.. totally get it now haha.



Jup thats how it works. Those values are only redrawn when you update the 'screen', so if you change from one char to another I think they also update (not sure though).

Originally by: Disco Jack

Not sure why the pics aren't loading yet all the same.



The pictures aren't directly 'exported' from the game to either the forums or the API system. That takes a while. There is no transparency on when or how it happens but over time the picture is generated and the API system will provide it. So if you see your picture on the forums here, only then you might see it in the MET (Mac Eve Tools). Although I'm not sure if MET refreshes the picture automagically or if you have to throw it away to refetch it, flammard can provide that info I guess.

Originally by: Disco Jack

One more thing I've noticed with the training plan. If you partially trained a skill, and then removed it from your queue until a more convenient time to finish, the training plan does not reflect the correct progress. The "Training Time" column shows the time remaining for that level of the skill, and the progress shows 0%.



This is due to the API system. When there is a partially trained skill as the current training skill it shows the current SP already trained when you resumed the skill as the 'start' value, but it forgets to mention that you already trained the skill partially. Thus when you calculate the progress using the start, end and current value the API gives you'll end up with the current result.

So to calculate a 'correct' progress, if that is the correct, you either needed to rummage in the datadump to get the rank of the skill and fully calculate the new progress bar, or we live with the current status, which isn't bad at all, because the 'progress' is simply the progress you made since you last 'resumed' the skill.

Leucippus
Apostasy Inc.
Posted - 2010.02.13 16:53:00 - [320]
 

The program has stopped working for me. I've deleted my local support files and reinstalled but that has not helped.

Here's what may have happened: A few days ago I created two alts, just for fun. I then deleted them. I also had EVE generate a new limited API key for me. All these little changes seem to somehow now prevent the program from loading up my main's data. It's a drag because the program is otherwise really great! Crying or Very sad

Disco Jack
Posted - 2010.02.13 17:51:00 - [321]
 

Edited by: Disco Jack on 13/02/2010 17:52:22
Originally by: Rottenator
...
This is due to the API system. When there is a partially trained skill as the current training skill it shows the current SP already trained when you resumed the skill as the 'start' value, but it forgets to mention that you already trained the skill partially. Thus when you calculate the progress using the start, end and current value the API gives you'll end up with the current result.

So to calculate a 'correct' progress, if that is the correct, you either needed to rummage in the datadump to get the rank of the skill and fully calculate the new progress bar, or we live with the current status, which isn't bad at all, because the 'progress' is simply the progress you made since you last 'resumed' the skill.


Well, the total times and the remaining times are listed in the skill information window that the app has, I figured it wouldn't be too hard to use the values from the info window in the formula, then again I don't know how messy that might be to reproduce and hold for all other skills and times so I'll leave that to people who do a lot more programming than me hehe.

Originally by: Leucippus
The program has stopped working for me. I've deleted my local support files and reinstalled but that has not helped.

Here's what may have happened: A few days ago I created two alts, just for fun. I then deleted them. I also had EVE generate a new limited API key for me. All these little changes seem to somehow now prevent the program from loading up my main's data. It's a drag because the program is otherwise really great! Crying or Very sad

You did update your API information with the mac eve tools app right? If you create a new API and don't let the app know what the knew API is (Along with new account number.. i think) then you're not going to get it to work.

By alts do you mean alt accounts? or alt characters under the same account/API?

Cyllena
Amarr
Imperial Shipment
Posted - 2010.02.14 08:35:00 - [322]
 

Edited by: Cyllena on 14/02/2010 08:36:27
Disco Jack: Your portrait get updated, when it is in the api. Mine isnt in the Api right now too :(

To the trainingtimes: Only the blue one it a countdown, the others (reds) are static and get updated, when the charsheet is refreshed. To refresh it, change to skillplaner and back to the charsheet or refresh your char.

Edit: I see what you mean. The red times are a bit laggy and two mins longer then the blue. The blue time is the right i think :)

Disco Jack
Posted - 2010.02.14 20:44:00 - [323]
 

Originally by: Cyllena
...
I see what you mean. The red times are a bit laggy and two mins longer then the blue. The blue time is the right i think :)


Eh, blues are indeed static until refreshed.

Hrmm.. I think we can all agree the functionality of the app is doing really good, and it looks good and accurate as long as the API server is up and you've recently refreshed.

What could be improved later for another version is to maybe have the queue countdown based on it's last refresh and even knock learned skills off the queue without needing to refresh the API (especially for times when API is not available at the time).

Logged on today knowing I only had 2 hours left on my last skill in queue but the app still had 3 skills showing as in the queue. It's minor though, but if you're fiddling with the code later on, something to consider.

Flammard
Caldari
The New Era
C0NVICTED
Posted - 2010.02.15 00:54:00 - [324]
 

Originally by: Leucippus
The program has stopped working for me. I've deleted my local support files and reinstalled but that has not helped.

Here's what may have happened: A few days ago I created two alts, just for fun. I then deleted them. I also had EVE generate a new limited API key for me. All these little changes seem to somehow now prevent the program from loading up my main's data. It's a drag because the program is otherwise really great! Crying or Very sad


Did you put your newly generated API key back into the program? When you said you deleted the local support files, what exactly did you delete?
-----

In answer to some above questions, Pictures are never updated. You would have to manually delete the portrait.jpg from the data directory (~/Library/Application Support/MacEveApi/<accountid>/<characterid>)

I'm looking into adding a portrait update button, but due to the way the code is written it's not as simple as it sounds.

I'll investigate the progress for a partially-trained-then-paused skill. I wasn't aware that was happening.

The countdown times circled in red don't update automatically. I had some trouble getting it to happen every second. Sometimes it would update every second, then every 3 seconds, then every 2 seconds and it just looked stupid. It's not really a high priority fix for me at the moment.

As for knocking already completed skills off the training queue, no. It adds far too much complexity.

Disco Jack
Posted - 2010.02.15 02:56:00 - [325]
 

Originally by: Flammard
...
As for knocking already completed skills off the training queue, no. It adds far too much complexity.



You're already the man in my eyes :) if it's that complicated then meh, it's only a very very minor thing anyways. The API system is usually up, and I'm using your app now to follow a very lengthy training regime for my alt. It has a special place on my dock right next to the Eve launcher :D

Disco Jack
Posted - 2010.02.17 19:31:00 - [326]
 

I have MacEveApi running on an intel iMac with snow-leopard, and on an old PPC iBook G4 with leopard. The app works great on both except that on the PPC the info windows do not show up for ships, skills still pop-up.

Is this an OS specific difference or perhaps the code for the ship info-windows doesn't like the old PPC processors...?

Flammard
Caldari
The New Era
C0NVICTED
Posted - 2010.02.17 23:56:00 - [327]
 

Originally by: Disco Jack
I have MacEveApi running on an intel iMac with snow-leopard, and on an old PPC iBook G4 with leopard. The app works great on both except that on the PPC the info windows do not show up for ships, skills still pop-up.

Is this an OS specific difference or perhaps the code for the ship info-windows doesn't like the old PPC processors...?


I stopped development on the old leopard version months ago. That version never had a ship details window. You can drag the ship into the plan though. I'm only releasing new versions for snow leopard now. Anyone is welcome to get the source and try to build a leopard version though.


By the way, I've fixed the bug where skill completion progress would get set to 0% when you paused and changed skills.

sikassLL
Posted - 2010.02.18 05:30:00 - [328]
 

Originally by: Flammard
Originally by: Disco Jack
I have MacEveApi running on an intel iMac with snow-leopard, and on an old PPC iBook G4 with leopard. The app works great on both except that on the PPC the info windows do not show up for ships, skills still pop-up.

Is this an OS specific difference or perhaps the code for the ship info-windows doesn't like the old PPC processors...?


I stopped development on the old leopard version months ago. That version never had a ship details window. You can drag the ship into the plan though. I'm only releasing new versions for snow leopard now. Anyone is welcome to get the source and try to build a leopard version though.


By the way, I've fixed the bug where skill completion progress would get set to 0% when you paused and changed skills.


Hey, wanted to thank you for the excellent tool you provide...I was wondering if you thought about converting the app to Adobe Air...anyways thanks again :)

Blasphemour
Posted - 2010.02.18 19:25:00 - [329]
 

OK I might be out of the loop a bit, but did you take the import/export function out again?

Alx Vauxserusier
Gallente
Center for Advanced Studies
Posted - 2010.02.25 05:16:00 - [330]
 

For the record: downloaded, used regularly, much appreciated.

Thanks,
-A


Pages: first : previous : ... 7 8 9 10 [11] 12 13 14 15 ... : last (19)

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only