open All Channels
seplocked Issues, Workarounds & Localization
blankseplocked Investigating Socket Closed Errors - How You Can Help
 
This thread is older than 90 days and has been locked due to inactivity.


 
Pages: first : previous : ... 6 7 8 9 [10] 11 12 13 14 ... : last (16)

Author Topic

Savatar Mei
Posted - 2009.12.24 19:59:00 - [271]
 

over 100k hit on google for this.

it isnt an isolated incident.

Millimage
Minmatar
Republic Military School
Posted - 2009.12.24 21:54:00 - [272]
 

Originally by: Savatar Mei
over 100k hit on google for this.

it isnt an isolated incident.


Yeah, from the forum posts I gather that it isn't isolated. I think there is something very fragile about the Eve connection protocol and when you get a bad enough route all things go to hell. Maybe Dominion borked something in the code or maybe I just got a bad server added to the route. I really don't know.

I just hope someone can figure this out and fix it soon. Not much point in paying for training.

Alyss Rentori
Gallente
The Scope
Posted - 2009.12.25 11:13:00 - [273]
 

I lost my beautiful Thorax recently to these connection problems.. It is very strange:
The first day, I had absolutely no disconnects, at all.
After the first daily maintenance, I disconnect every 3-4 minutes, rarely lasting longer than this.

Where do I submit these socket closed logs to?

Alyss Rentori
Gallente
The Scope
Posted - 2009.12.25 11:40:00 - [274]
 

Actually, I should mention this is the very first time I lost a ship, usually I login and find myself starting to warp back to wherever I was at a distance of 1 million km, which is really, really nice!

Unfortunately, this last time, the pirates had some glowy thing on me, I think it was a web, but it was possibly a warp disruptor. I think that's how they got me. That's all I really saw though.

Devilsown
Posted - 2009.12.30 08:15:00 - [275]
 

Quote:
The IP is 85.90.238.58 (doesn't give a dns name) and the packet loss percentage is around 60-70% constantly.



This happens to me too on the same server and on top of that the ccp one gives me a 500ms responce when the socket loss is there.

Kestrix
Posted - 2010.01.03 15:08:00 - [276]
 

I've recently been getting alot of 'socket closed' errors. I'm with Virgin Media and my connection speed was recoreded bettween 6 and 7 Mb/s by http://www.speedtest.net/ and I was getting a grade F with http://www.pingtest.net/ I was connecting to a Linksys router and then to my modem. After removing the Router and connecting directly to my modem my pingtest results went from F to B and I've *touches wood* not had a 'socket closed' error since. Hope this helps.

Kestrix

Millimage
Minmatar
Republic Military School
Posted - 2010.01.04 08:23:00 - [277]
 

Originally by: Kestrix
I've recently been getting alot of 'socket closed' errors. I'm with Virgin Media and my connection speed was recoreded bettween 6 and 7 Mb/s by http://www.speedtest.net/ and I was getting a grade F with http://www.pingtest.net/ I was connecting to a Linksys router and then to my modem. After removing the Router and connecting directly to my modem my pingtest results went from F to B and I've *touches wood* not had a 'socket closed' error since. Hope this helps.

Kestrix


Yes, connection quality seems to be the source of the problem but something has changed in Dominion that makes it a gamebreaker (for me, at least). For instance, I know pretty much for certain that my "socket closed" errors are caused by a bad line. But as far as I know the line has been the same for years and only after Dominion did I start to get disconnected.

Running pingplotter I can say beforehand when I'm going to get disconnected if I do certain things ingame. From time to time I get a 10-15 second period of packet loss (red blocks in pingplotter standards time graphs) on my first hop (to ISP).

If I perform an action that requires a response from the server (like jumping a gate or updating a market order) with the packet loss occurring I will at first get a client that responds to user actions but does not update the world in any way. This is pretty soon followed by a "socket closed" error and then the client restarts.

That all sort of makes sense. The client tries to get a response from server, can't get one and decides to throw in the towel. Of course if the client would care to wait for the 10-15 seconds for the problem to pass things would get back to normal and everything would be fine and dandy.

While Eve has been unplayable I've been trying out LotRO and while I can see the packet loss as a game freeze there too, it does not throw me out like Eve. The world simply stops updating and returns to normal action when the problem subsides.

I've been in contact with my ISP and they have tried lowering my connection speed in hopes that it would fix the problem. So far that has not helped. I will continue trying to improve the connection with them but as I live in the countryside there are only so many things that can be done. And I'm not willing to go down very far with my connection speed as the only thing that is not working is Eve.

Hopefully someone at CCP wakes up and picks up this issue. I love the game, but I'm not willing to pay for training and trading on the market as that is pretty much what I'm reduced to with the way things are at the moment.

Devilsown
Posted - 2010.01.04 10:51:00 - [278]
 

It might be to soon to cheer, but i did the following to at least until now fix the problem.
*knocking on wood*

I went into the router setup and in the WAN Setup

Disabled SPI Firewall

NAT Filtering, Disabled SIP ALG

This is on a Netgear Wrn3500 (N300) wireless router.

Last night i played without the socket loss errors. Thus so far i am happy, although knocking on wood.

Agrilad
Posted - 2010.01.05 12:34:00 - [279]
 

I was getting socket closed errors quite often last week. About Saturday I started connecting it to docking of my iphone to the computer. And itunes syncing to that iphone.

While itunes was syncing to the iphone. I couldn't check my email, couldn't read any web page. But most importantly for this forum. Eve gave me a socket closed error.

Korinthius
Caldari
UNAS Corp
Posted - 2010.01.05 22:08:00 - [280]
 

Not sure if this will help everyone, but it has resolved the Socket Closed issue for multiple corp members. Heres what we found and what we did to resolve the issue.
For the last 2 weeks we have been getting an increased number of socket closed errors. Originally this would only happen once or twice a day, but quickly escalated to 5-6 times an hour. Not good while running missions as we all know.
When the issue became really bad for me and my roommate, we started thinking we had a bad router, and went through the logs. In the logs, we found hundreds of packets lost in just mere moments. The log only held 20 pages of info, and within 10 mins, the whole log had been refilled. While following some other posts we found on the web we began troubleshooting.
During the Troubleshooting process, we played with a few settings, such as turning gaming mode off, UPNP Settings we disabled, and Discard PING from WAN side was enabled. While these changed did NOT resolve the issue, we found a new problem. In the logs, alot of the packets lost we now changed to "Smurf Attack Detected". The little blue buggers we messing with my router? j/k. Through more research, we found a resolution to this problem as well. We changed the router so we were not longer on a 192.168.0.X network to a 192.168.1.X network.

Results = 36 hours of no Socket Closed Errors, and packets dropped went from 100 per min average to 6 per HOUR. Result = 2 Happy Eve Players.
We recommended this fix to other people in the corp who were having the same problem, and they are rocking Tranquility with the rest of the corp again.

The fix may require as little as the IP change or as much as all 4 items we changed, but TBH, I am not going back and testing that theory under threat from my roommate to smack me with a frying pan if he loses connection again.

Network Hardware In Use
Bell Speedstream 5200 DSL Modem
D-Link DI-624 Airplus Extreme G Wireless Router

Hope this helps others out there ( Donations Welcome ), not sure if these suggestions have been posted before and I appologize if I am repeating someones previous post

Millimage
Minmatar
Republic Military School
Posted - 2010.01.06 08:42:00 - [281]
 

Originally by: Korinthius
[stuff on how to fix a connection problem]


Glad to hear you got your connection fixed. I'm sure that may prove helpful for some others too, but the problem is two-fold (in my opinion).

The people suffering from "socket closed" errors are ones with bad connections (packet loss occurring etc.) and they can get their connection fixed to fix the problem with Eve. I'm trying to do this with my ISP, you got yourself sorted out by tweaking your router.

On the other hand we all know (or at least that's my conclusion based on all the evidence so far) that Dominion started a new outbreak of the "socket closed" errors. Something changed in Eve (client, server, connection protocol, whatever) that made the game a lot more susceptible to errors from bad connections.

This can (hopefully) be fixed by CCP by reworking the changed part. To me this sounds the more reasonable solution as it would most likely solve the problem for the majority of player now suffering from "socket closed" errors. By making the game not disconnect from a short periods of packet loss etc. would make the game at least playable with a bad connection.

It may well be that the extra load (planets and whatnot) that Dominion brought has proven too much for the game as it is. We are seeing major lag, big fleet battles are a no-no, disconnects happening... everything says there are some serious problems with the current version and improving the connection handling may not be a top priority for CCP right now.

So my suggestion for everyone is to try to fix the connection on your end (call your ISP, tweak your hardware, etc.) because fixing the bad connection removes the source of the errors. This may not be possible for everyone (me included it seems), but at least it is a part you can directly try to affect.

Meanwhile we can only hope that CCP is on the ball and a solution is being worked on their end too. I'm certain they are aware of the issue, but whether they are currently working on it is another matter. But a little status update/"hello, we are still here" would be nice, devs...

xo3e
The Deliberate Forces
HYDRA RELOADED
Posted - 2010.01.06 23:07:00 - [282]
 

what the hell is happening??

last few days me and my corpmates start to experience frequently disconnections (every 1-5 minutes or so). Not all day long, but periodically.

iv never seen such large amount of disconnections on "square metre". Today our almost entire gang was disconnected in the middle of a fight.
but not everyone was disconnected =\\. for example my alt in second window was fine, while main window get "socket closed" message, and few of my corpmates experienced the same (main char disconnected, but alt stayed online).

i was in "WTF??". iv decided to run ping to eve-online.com and google.com at the same time, and sit and watch.

And long check has shown, that eve-online "disappearing" for a few second (yes, every 1-5 minutes, periodically), while google.com ping is fine.

so, i think it is CCP or its main ISP problem, and not my or my friends ISP.


Millimage
Minmatar
Republic Military School
Posted - 2010.01.07 06:55:00 - [283]
 

Edited by: Millimage on 07/01/2010 06:57:54
Originally by: xo3e
And long check has shown, that eve-online "disappearing" for a few second (yes, every 1-5 minutes, periodically), while google.com ping is fine.

so, i think it is CCP or its main ISP problem, and not my or my friends ISP


Well, I still think the problem is in that the client can't handle a bad connection. A short period of packet loss results in a "socket closed" dc and client reboot.

Like I said earlier, the source of the bad connection may vary from person to person (and I'd imagine a problem with CCP ISP should affect quite a few) but it isn't the actual problem. I might be wrong, of course. Smile

EDIT: Btw, did you run a tcp trace or the default ICMP trace? Some servers will quite often drop the ping echo requests when they are heavily loaded so that doesn't give you the whole picture. Of course the Eve servers don't seem to respond to tcp traces, so that's not very helpful either... Very Happy

Millimage
Minmatar
Republic Military School
Posted - 2010.01.08 07:00:00 - [284]
 

I hope I'm not jumping the gun here, but I may have had my problem solved. I played for a couple hours last night without any disconnects.

My ISP finally got around to lowering my connection speed from 8Mb to 2Mb and all packet loss peaks from my first hop vanished. This was what we expected as it is a very long line and just couldn't seem to handle the higher speed. The result so far has been a smooth Eve experience.

I can only repeat my recommendation that you check your connection quality and try to improve it if you are experiencing the "socket closed" disconnects. I'm sure the source of a bad connection is beyond the reach of some people, but if you happen to be lucky and can improve it you just might rid yourself of the disconnects.

Xeross155
Minmatar
NED-Clan
Goonswarm Federation
Posted - 2010.01.10 21:21:00 - [285]
 

When I click the link to the SiSi topic I get the error that I try to post in a locked thread :/

Kraven Drakenovic
Posted - 2010.01.13 03:23:00 - [286]
 

well i was following the recommendations... bam down goes another client, you'll love this bit i was trying to submit a petition at the time and now i have no submissions and it just Dc'd again hooray Evil or Very Mad the bit i love the most is how much isk im loosing being Dc'd before my hulk can finish the cycle or it will DC whilst im transferring ore then i log bak in and have a full cargo bay. its like nails on a chalk board when u have 7 days too accumulate a billion isk

Kraven Drakenovic
Posted - 2010.01.13 03:30:00 - [287]
 

screw it with 12 dc's in an hour im over it hell 3 client disconnects whilst posting on the forum ****d up much? never had a problem till dominion i know its not my net .. im cable hardline with the best net i can get in australia... my thoughts is it might have something to do with the australian government introducing mandatory ISP level filtering and monitoring, something CCP might want to check is the % of users who are on australian ISP's experienceing these difficulties

Dixon Oreole
Posted - 2010.01.14 14:43:00 - [288]
 

Just to get things straight is this Socket closed error the same as the crash error a lot of people are having? (When there are lot of ppl in system eve starts to crash)

Wastes
Posted - 2010.01.15 17:10:00 - [289]
 

Edited by: Wastes on 15/01/2010 17:12:21
This has been happening to me for about a week now. I open eve, I log in, while the character selection screen is loading the client restarts.
When I was finally able to get on eve I changed the 'restart client when connection lost' setting.
Now when it fails (same as before) it says blah blah blah socket was closed, then immediately another message saying 'connection was lost'.

ExclamationI can get on to eve some times but I am losing hours of gameplay because of this borked system. Exclamation

CCP pull ur fingers out.Rolling Eyes

Since I started playing I have only missed 19 hours of skill training time and I will not lose any more because of this.Twisted Evil

N1kel
Posted - 2010.01.18 21:42:00 - [290]
 

same socket closing every 10 mins..

C:\>tracert eveonline.com

Трассировка маршрута к eveonline.com [87.237.39.196]
с максимальным числом прыжков 30:

1 1 ms <1 мс <1 мс 192.168.1.1
2 21 ms 21 ms 21 ms vl-cen-bas3.avtlg.ru [83.239.128.229]
3 21 ms 21 ms 21 ms 83.239.151.241
4 21 ms 21 ms 21 ms 83.239.129.82
5 22 ms 21 ms 21 ms ae-0.vgrd-rgr1.ug.ip.rostelecom.ru [87.226.141.1
25]
6 113 ms 113 ms 113 ms xe-1-0-0.frkt-ar2.intl.ip.rostelecom.ru [87.226.
133.110]
7 124 ms 357 ms 360 ms decix.telecitygroup.net [80.81.192.103]
8 118 ms * 119 ms 85.90.238.58 WTF?!
9 * * 758 ms 85.90.238.58 WTF?!
10 118 ms 117 ms 120 ms 85.90.238.54
11 123 ms 121 ms 122 ms ipt-ccp-games-1-as35834.lon3.telecity.net [217.2
0.44.138]
12 121 ms 122 ms 121 ms 87.237.36.22
13 122 ms 122 ms 121 ms 87.237.39.196
Трассировка завершена.

http://www.ip-address-lookup-v4.com/lookup.php?ip=85.90.238.58 - here shown that IP-adress, which causes troubles, belongs to British ISP, so guys you can`t do anything.. Those who don`t have 85.90.238.58 in their route to eve-server are just lucky ones.

http://www.eveonline.com/ingameboard.asp?a=topic&threadID=921650&page=45 - same issue

N1kel
Posted - 2010.01.18 23:56:00 - [291]
 

O_o Problem solved Exclamation I`ve changed the IP-range on my router for intranet - dunno why, but it helped.. No more lags on 238.58 :)

gothicseraphX2
Posted - 2010.01.19 16:51:00 - [292]
 

I just installed dominion and under tranquility the server status is unknown. I tried logging in and keep getting the same 'you are not connected to to the internet or have entered a wrong ip address for the server' message. I know my internet connection is fine so what can be wrong?

Muad' Dib
Gallente
PWNED FACTOR HOLDINGS
Posted - 2010.01.20 18:20:00 - [293]
 

Edited by: Muad'' Dib on 20/01/2010 18:22:12
This thread needs to remain at the top, so that the ***gots working on this from CCP - i hope some are working on this, can't just shove it under the carpet.

My adress range in intranet is .2.xxx and i still get it.
Usually in very big systems i have the problem but i also see it from time to time with systems of 100+.

This is a problem they admitted plagues EVE for 15 months now, and their only solution so far has been to disable the socket closed text when you get the issue and your not doing something on the client. :(

En Drian
Posted - 2010.01.23 14:01:00 - [294]
 

Well pinplotter confirms this. Same as a number of others. Everything is fine until hitting 87.237.36.22 - then packet loss hits 100%. I don't yet know who this is, but they are the problem for myself and some local players.

Kansas City, Missouri, USA

Kyle Reel
Gallente
Posted - 2010.01.23 17:42:00 - [295]
 

Edited by: Kyle Reel on 23/01/2010 17:47:45
I also suffer from socket issues.

I'll try to do some more testing on this, but I seem to be mostly affected during peak Europe usage hours (late evenings on GMT+1/GMT+2/GMT+3 timezones).
After Dominion 1.1 deployment I was able to log on and play continuously for several hours and so I though the issue was finally gone. That was at approx. 17:00 GMT+2. Unfortunately after logging in later (~22:00 GMT+2) I suffered from socket issues every five minutes.

I'm flying mostly in Fricoure and Vitteryn. During my first logon (without issues) there were ~120 people in Local in Fricoure and ~80 in Vitteryn (~35k on server total). During the second time (with socket errors) there were ~150 people in Local in Fricoure (~50k on server total). I didn't make it to Vitteryn, so I don't know how many people were there.

I'm normally using Linux and using wine to run Eve, but socket issues remained even after booting to Windows. Switching the local net addresses from 192.168.1.0/24 to 192.168.42.0/24 range didn't help either.

Traceroute shows that my connection passes through 80.81.192.103 (decix.telecitygroup.net, first address after my ISP) and 85.90.238.54 before hitting ccp servers.

Edit: To clarify: I originally started having this problem some time after Dominion deployment (the expansion, not the 1.1 patch). Luckily I have some very long skills to train...

mechtech
SRS Industries
SRS.
Posted - 2010.01.26 21:27:00 - [296]
 

After resuming from sleep, the clients (I run around 5 clients usually) became unresponsive and I got a "lost connection" message.

I don't know if this is part of the bug, or simply because eve doesn't resume after sleep mode, but either way it would be nice if sleep was supported.

Nomen Clay
Posted - 2010.01.27 05:35:00 - [297]
 

Both my home cable line and my iphone tethering have this problem. I can sometimes go for hours perfectly normal gameplay and then 20-25 seconds of no reaction to any buttons i press followed by a socket closed message.

Once it happens one time it becomes much more frequent there after. Any word on this would be much appreciated by all the above posters as well as me :)

DeMichael Crimson
Minmatar
Republic University
Posted - 2010.01.29 13:00:00 - [298]
 

I get 'Socket is closed' and 'Connection lost' and also sometimes Eve will just crash with a 'Send error report'. I don't get it very often but when it does happen, it happens at random times, will be jumping at a gate or sitting in a station, doesn't matter if inactive or active. I've noticed it happens to a lot of players at the same time when there's about 40k and up online. Then it's all about being a number in Queue waiting/trying to re-log. I never had this problem before and I haven't changed anything in my computer nor will I mess around with the Cable or the router/modem which is owned by Time Warner Cable Company in Southern California. I know it's not on my side and I have seen it happen to a lot of players. Next time you log in, check how many players are online and then see how many players are online after the socket crashes. This is just like what America does during the summer to reduce the strain on the electric power plants, it's called a 'Rolling Blackout'.

Denalak
Gallente
Maelstrom Crew
Posted - 2010.01.31 08:36:00 - [299]
 

So has this been fixed? I havent disconnected since our last patch. I dont want to jump the gun though and jinx it , but I have noticed I can afk for a long time without coming back timed out, our waiting to crash as soon as I session change.

Anyone else see any differences or no?

Socket Closed
Posted - 2010.02.03 00:45:00 - [300]
 

Originally by: Denalak
So has this been fixed? I havent disconnected since our last patch. I dont want to jump the gun though and jinx it , but I have noticed I can afk for a long time without coming back timed out, our waiting to crash as soon as I session change.

Anyone else see any differences or no?


The problem is still there for me.

Had a few times during my trial (almost a month ago) where I would get a lot of them in a small amount of time, so I petitioned,etc. The GM, while friendly, did'nt manage to help fix it (at least he tried and asked for logs,etc.). Since the DCs were less frequent than in the beginning (I could play ~1hr+ without getting disconnected), and more importantly, because I love the game, I decided to sub (and made this my main char so nobody is surprised if I disappear in the middle of a mission,conversation,etc. ;) ).

Anyways, it's been 3+ days in a row where it's simply unplayable for me. I can now stay connected at most 5min. It's getting old fast I must admit (I spend all my time "warping back" to where I was..). It may be an issue with my connection like CCP is saying, but since it's the only game where I have seen this, I'm bound to think otherwise.

Whatever it is, it's a real test of patience.. one that I'm not sure I'm willing to pay for if there are no possible explanation/fix on the horizon.



Pages: first : previous : ... 6 7 8 9 [10] 11 12 13 14 ... : last (16)

This thread is older than 90 days and has been locked due to inactivity.


 


The new forums are live

Please adjust your bookmarks to https://forums.eveonline.com

These forums are archived and read-only